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Getting Started

Building a Deployable Application Describes the sequence of steps
(p. 1-2) needed to create and deploy an
application.



1 Getting Started

Building a Deployable Application

Using MATLAB® Builder for Excel to create a deployable application is a
simple process requiring a sequence of six steps. For details see

® “Creating a Project” on page 1-3

® “Managing M-Files and MEX-Files” on page 1-6

e “Building a Project” on page 1-7

e “Testing the Model” on page 1-9

e “Application Deployment” on page 1-10

e “Packaging and Distributing the Component” on page 1-10

This section references various menus provided by the Excel Builder graphical
user interface (GUI). For a full discussion of these menus, see Chapter 2,
“Graphical User Interface”

Elements of an Excel Builder Project

A project consists of all the elements necessary to build a deployable
application using Excel Builder. Excel Builder components are COM objects
accessible from Microsoft Excel through VBA. COM is an acronym for
Component Object Model, which is Microsoft’s binary standard for object
interoperability. Each COM object exposes a class to the Visual Basic
programming environment. The class contains a set of functions called
methods, corresponding to the original MATLAB functions included in the
component’s project.

Note Currently, Excel Builder components support one class per component.

Classes

When creating a component, you must additionally provide a class name.
The component name represents the name of the Dynamic Load Library
(DLL) file to be created. The class name denotes the name of the class that
performs a call on a specific method at run-time. The relationship between
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Building a Deployable Application

component name and class name, and which methods (MATLAB functions)
go into a particular class, are purely organizational. As a general rule,
when compiling many MATLAB functions, it helps to determine a scheme of
function categories and to create a separate class for each category. The name
of each class should be descriptive of what the class does. Organizing related
functions into classes in this way has the added advantage of reducing the
amount of code to rebuild and redeploy when one function is changed.

Versions

Excel Builder components also support a simple versioning mechanism.

A version number is attached to a given component. This number gets
automatically built into the DLL file name and the system registry
information. As a general rule, the first version of a component is 1.0 (the
default value if none is chosen). Changes made to the component before
deployment keep the same version number. After deployment, change the
version number for all subsequent changes, so that you can easily manage
the new and old versions. The system sees classes in different versions of the
same component as distinct, even if they have the same name.

Creating a Project

To begin project creation, enter the MATLAB command mx1tool at the
command line. The MATLAB Builder window appears.

1-3



1 Getting Started

«): MATLAB Builder

File Project Build Component Help
rProject File Build Statu

Aol EilE |

# ProjectFiles

Edit | BErmaye | E{ear

MATLAB Builder Window

For a complete description of the features available from this window, see
“Graphical User Interface Menus” on page 2-2.

Select File > New > Project to view the Project Settings dialog box.

14
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«): New Project Settings 10l =|
rProject naming

Component name

Classes

Class name

I Add ==
Remaove

Froject version

Froject directary

Erowse... |

rCompiler aption

[ Creste s singleton MCR
™ Build debug version

[ Show verbose output

QK | Cancel | Help |

New Project Settings Dialog Box

Component name denotes the name of the DLL created later in the build
process. After you enter the component name, the GUI automatically enters
a Class name identical to the component name. You can change the class
name to something more descriptive. Although the component name and class
name can be the same, the component name cannot match the name of any
M- or MEX-files added to the project later. For Excel Builder, the Create a
singleton MCR option is always on, whether or not the box is selected.

The Project version default value is 1.0. See “Versions” on page 1-3 for
additional information about Project version.

Project directory specifies where any project and build files are written
when compiling and packaging your models. The project directory is
automatically generated from the name of your current directory and the
component name.
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Note You can accept the automatically generated project directory path or
choose another of your liking. Once you click OK on this menu, this path is
saved. If you later decide to move the project or change anything on its path,
you need to redo the entire project specification process, including adding files
to the project (see “Project Settings Window” on page 2-7) and respecifying the
project directory path.

You can create a debug version of your compiled models and can specify
verbose output when you invoke the MATLAB Compiler. The debug option
enables you to backtrace up to the point where you can identify if the failure
occurred in the initialization of MCR, the function call, or the termination
routine.

Once you accept these settings on the New Project Settings dialog box by
clicking OK, they become part of your project workspace and are saved to the
project file along with the names of any M- or MEX- files you subsequently
add to the project. A project file of the name <component name>.mx1 is
automatically saved to the project directory.

Managing M-Files and MEX-Files

After you create a project, you enable the “Project Menu” on page 2-3, “Build
Menu” on page 2-4, and “Component Menu” on page 2-4 items in the menu
bar of the MATLAB Builder window.
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«): MATLAB Builder - myprimes.mxl

File Project Build Component Help
rProject File Build Statu

Add File |

|1 ProjectFiles

E—J myprimes
#* hi-files
* MEX-Ailes

Edit | Remuove | Clear |

MATLAB Builder Window with Options Activated

Add M- and/or MEX-files to the project by clicking the Add File button or
selecting the Project > Add File menu choice. You can add only a single
file at a time to the project.

Note The name of any file added to the project cannot duplicate the name of
any function existing in the library of precompiled functions.

The Remove button or Project > Remove File menu choice removes any
selected M- or MEX-files. You can highlight multiple files for removal at one
time.

The Edit button, the Project > Edit File or double-clicking an M-file
name opens the selected M-file(s) in the MATLAB editor for modification or
debugging. You cannot edit MEX files.

Building a Project

After you define your project settings and add the desired M- and MEX-
functions, you can build a deployable DLL and the necessary Visual Basic
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for Applications (VBA) code that allows Excel to access the DLL. Choosing
Build > EXCEL/COM Object invokes the MATLAB Compiler, writing
the intermediate source files to <project _dir>\src and the output files
necessary for deployment to <project dir>\distrib.

Command Line Interface

Alternatively, you can invoke the MATLAB Compiler directly via the mcc
command using the MATLAB command line interface. See the MATLAB
Compiler documentation for a description of the mcc command and its options.

Note If you use mcc directly, the <project _dir>\src and

<project _dir>\distrib directories are not automatically created. To create
these directories and copy associated files to them, use the mcc command’s -d
switch.

On the command line use the excel wrapper option to create Excel COM
components with mcc, as follows:

mcc -W excel:<component_name>[,<class_name>[,<major>.<minor>]]

An unspecified <class_name> defaults to <component name>, and an
unspecified version number defaults to the latest version built or 1.0, if there
is no previous version.

The following example shows the mcc command used to create a COM
component called mycomponent containing single COM class named myclass
with methods foo and bar, and a version of 1.0:

mcc -W excel:mycomponent,myclass,1.0 -T link:1lib foo.m bar.m

Use the -b switch to generate an Excel-compatible formula function for each
M-file on the command line:

mcc -W excel:mycomponent,myclass,1.0 -b -T link:1ib foo.m bar.m

You can also use the cexcel bundle file to simplify the command line input, as
follows:
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mcc -B cexcel:mycomponent,myclass,1.0 foo.m bar.m

The cexel bundle option automatically includes the -b switch.

Build Status

The Build status panel shows the output of the build process and

informs you of any problems encountered. The files appearing in the

<project _dir>\distrib directory will be a DLL and a VBA file (.bas). The
resulting DLL is automatically registered on your system.

To clear the Build status panel, select Build > Clear Status. The output
of the build process is saved in the file <project dir>\build.log. To open
the Build Log, choose Build > Open Build Log. The Build Log provides a
record of the build process that you can refer to after you have cleared the
Build status panel. If you have reason to contact MathWorks Technical
Support with a question about the build process, you will be asked to provide
a copy of this log.

Testing the Model

At this point, you can test the model by importing the VBA file (.bas) into the
Excel Visual Basic editor and invoking one of the functions from the Excel
worksheet. To import the VBA code into Excel’s Visual Basic editor, open
Excel and choose Tools > Macros > Visual Basic Editor. From the Visual
Basic editor, choose File > Import and select the created VBA file from the
<project _dir>\distrib directory.

The Visual Basic module created when you build the project contains the
necessary initialization code and a VBA formula function for each MATLAB
function processed. Each supplied formula function essentially wraps a call
to the respective compiled function in a format that can be accessed from a
cell in an Excel worksheet. This function takes a list of inputs corresponding
to the inputs of the original MATLAB function and returns a single output
corresponding to the first output argument. Formula functions of this type are
most useful to access a function of one or more inputs that returns a single
scalar value. When you require multiple outputs or outputs representing
ranges of data, you need a more general Visual Basic subroutine. For a more
detailed discussion on integrating Excel Builder components into Microsoft
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Excel via Visual Basic for Applications, see Chapter 3, “Programming with
MATLAB Builder for Excel”.

Application Deployment

Now create an Excel add-in (.x1a) from your VBA code. Return to
the Excel worksheet window and save the file as an .x1la file to the
<project_dir>\distrib directory.

Here are the steps necessary to create an Excel add-in from the generated
VBA code. If these steps do not work, refer to your Excel documentation on
creating a .xla file:

1 Start Excel.
2 Choose Tools > Macros > Visual Basic Editor.

3 In the Microsoft Visual Basic window, choose File > Import.

H

Select VBA file (.bas) from the <projectdir>distrib directory.

Close the Visual Basic editor.

(%))

6 In the Excel worksheet window, choose File > Save As .
7 .Set the Save as type to Microsoft Excel add-in (*.x1a).

8 Save the .xla file to <projectdir>\distrib.

You can also deploy files in *.x1s and *.bas formats. To deploy in *.x1s
format, follow the steps above but change the Save as type in Step 7 to *.x1s.
To deploy as VBA code, follow Steps 1 - 4 above only.

Packaging and Distributing the Component

Once you have successfully compiled your models and created the Excel
add-in, you are ready to package the component for distribution to your end
users.

Choose Component > Package Component to create a self-extracting
executable containing these files.
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File

Purpose

<componentname>.ctf

Component Technology File
archive; platform-dependent
file that must correspond to
the end user’s platform

<componentname_projectversion>.dll

Compiled component

_install.bat

Script run by the
self-extracting executable

MCRInstaller.exe

Self-extracting MATLAB
Component Runtime library
utility; platform-dependent
file that must correspond to
the end user’s platform

*.xla

Any Excel add-in files found in
the <projectdir>\distrib
directory.

MCRInstaller.exe installs MATLAB Component Runtime (MCR), which
you need to install on the target machine once per release. You can find the
steps needed to deploy an application on a target machine in the MATLAB

Compiler documentation.

To use the Excel add-ins, start Excel, choose Tools > Add-Ins, and select

the desired .x1a file.

You must repeat this distribution process on each target machine.

1-11
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Graphical User Interface Menus
(p. 2-2)

Project Settings Window (p. 2-7)

Component Information Window
(p. 2-8)

Package Files Window (p. 2-9)

Describes the available set of menus.

Discusses how to use the project
settings menus to create settings for
a new project or to edit settings of an
existing project.

Shows details about components
created with MATLAB Builder for
Excel

Helps you specify and create a
self-extracting executable for your
component



2 Graphical User Interface

Graphical User Interface Menus

The MATLAB function mx1tool displays the MATLAB Builder window.

«): MATLAB Builder

File Project Build Component Help
rProject File Build Statu
A File |
# ProjectFiles
Edit | BErmaye | E{ear

The information below describes the use of the various menus that the
MATLAB Builder window provides. These menus are

¢ “File Menu” on page 2-2

® “Project Menu” on page 2-3

e “Build Menu” on page 2-4

® “Component Menu” on page 2-4

e “Help Menu” on page 2-6

File Menu
The File menu creates and manages MATLAB Buildef for Excel projects.
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Mew Project...
Open Project...
Save Project...
Save As Project...
Close Project
Close CMPTOOL

* New Project opens the New Project Settings dialog box. This menu item
creates a project workspace where you can add M- and MEX-files to the
project and store project settings.

* Open Project allows you to load a previously saved project.

* Save Project saves the current project. If you have not yet saved the
current project, you are prompted for a filename.

* Save As Project saves the current project after prompting for a filename.
® Close Project closes the current project.
¢ Close CMPTOOL closes the MATLAB Builder window.

Project Menu
The Project menu controls the management of the current project’s files.
add File...

Edit File...
Remave File

Settings...

¢ Add File adds an M-file or MEX-file to the current project. (The Add
File button in the Project files frame of the main window performs the
same task).

¢ Edit File allows you to edit the selected M-file. (The Edit button in the
Project files frame of the main window performs the same task.)

* Remove File removes the currently selected files from the project. (The
Remove button in the Project files frame of the main window performs
the same task.)

® Settings opens the project settings dialog box showing the current project’s
information. See “Project Settings Window” on page 2-7 for details.
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Build Menu

The Build menu controls the building of the project’s files into an
Excel-accessible COM object.

ExcelfCOM Object
Clear Status
Open Build Log

e Excel/COM Object builds project files into an Excel-accessible COM
object and generates Visual Basic Application code necessary to create
an Excel add-in. The Excel add-in adds the new function(s) to the Excel
function name space.

e (Clear Status clears the Build status window.

¢ Open Build Log displays project status that has been saved in this log file.

Component Menu

The Component menu completes the process of building a deployable
application.

Package Component

Component Info...

¢ Package Component readies files for deployment. The deployable
files are packaged in a self-extracting executable. Click on Package
Component to display the Package Files dialog box. See “Package Files”
on page 2-4 for details.

¢ Component Info displays a dialog box with information about the current
project’s component and component versions. See “Component Information”
on page 2-5 for details.

Package Files
The Package Files choice displays the Package Files dialog box.
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«): Package Files

Add File Remaove File

™ Include MCR

|| Package Files
# UserFiles
# System Files

Create... | Close | Help |

The Add File and Remove File buttons allow you to add or delete user
files to or from the package.

A check box allows you to include or exclude MATLAB Component Runtime
(MCR) from the package. MCR is a stand-alone set of shared libraries that
enables the execution of M-files. MCR provides complete support for all
MATLAB language features.

Use the MCR Location button to specify the directory location of
MCRInstaller.zip.

After you have specified the files that you want to include in the package, click
Create to initiate package creation.

Component Information
The Component Info choice displays the Component dialog box.
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Component - cbltest ! 10l =|

_4 Mame- CBLTEST
(- Wersion
B-291.0
------ # Type Library: chltest 1.0 Type Library
------ # Library [D:{0147EB2B-FECA-4515-9CB3-BAC3072ECADF}
------ # File Mame: diwoarkichltestidistribichitest_1_0.dll
B4 Classes
-4 Name: aaaclass
# Class Do {8F5BA0D22-FO5D-4803-99C1-F2EFFG500835}
Frogram ID: chitest.aaaclass.1_0
In Process Server: diwoarkichitestidistrinichitest_1_0.dIl
4 Methods
# function [¥] = showerrar{y)
Froperties
Events
-4 Interfaces
# Mame: [aaaclass
# Interface |D: {FE3307454-9459B8-4 CES-9D8B-CBAZEBATEFCTY 3}

E-)20
B ]3.0 -
Help | Close

This dialog presents the component information that is stored in the registry.

See “Registry Information ” on page 6-3 for more information about these
fields. The Methods list box shows the name and M-file calling syntax of
each function within the component.

Help Menu
The Help menu provides access to the context-sensitive help for the MATLAB
Builder window.

CMETOOL Help
MATLAB Bullderfor Excel ¥ waT) AR Builder for Excel Help
About MATLAE Builder for Excel




Project Settings Window

Project Settings Window

For new projects, click File > New > Project to open the New Project

Settings window.

For existing projects, click File > Open > Project > Settings to open the
Project Settings window.

The project settings are as follows:

Setting

Component name

Class name
Classes
Project version

Project directory

Compiler options

Description

Name of the component you are creating with this
project.

Name of a class that you want to add.
List of classes currently in this project.
Version number of this project.

Location for output files generated by Excel Builder,
including the project file

Check Create a singleton MCR if your users can
share a single installation of the MCR.

Check Build debug version to add debugging
information to the classes generated by Excel
Builder.

Check Show verbose output to display all details
and create a complete log of the build process.

Note See “Versioning” on page A-10 for more information about how Excel
Builder handles numbering of versions.
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Component Information Window
This listing presents the component information that is stored in the registry.

See componentinfo for an explanation of these fields.



Package Files Window

Package Files Window

Use the Package Files window to specify the files and properties that the
Builder should use to create a self-extracting executable for the component
that you have built.

Click Add File to add files to the package. You do not need to add any files
that are in the project.

Click Remove File to delete files from the package.

Click or clear the Include MCR checkbox to include or exclude MATLAB
Component Runtime (MCR) from the package. MCR is a stand-alone set of
shared libraries that enables the execution of M-files. MCR provides complete
support for all MATLAB language features.

Click MCR Location to specify the directory location of MCRInstaller.zip.

After you have specified the files that you want to include in the package,
click Create.

Here is an illustration of the Package Files window:

«): Package Files

Add File | Remaove File |

™ Include MCR

|| Package Files
# UserFiles
# System Files

Create... Close Help
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Programming with
MATLAB Builder for Excel

Overview (p. 3-2)

When to Use a Formula Function or
a Subroutine (p. 3-3)

Initializing MATLAB Builder for
Excel Libraries with Excel (p. 3-4)

Creating an Instance of a Class
(p. 3-6)

Calling the Methods of a Class
Instance (p. 3-9)

Processing varargin and varargout
Arguments (p. 3-11)

Handling Errors During a Method
Call (p. 3-13)

Modifying Flags (p. 3-14)

Introduction to this section.

Discusses the Visual Basic for
Applications (VBA) two basic
procedure types, functions and
subroutines.

Describes initialization of the
supporting libraries with the current
instance of Excel.

Discusses creation of an instance
of the class that contains a classs
method.

Describes calling a class method to
access compiled MATLAB functions.

Describes how to add varargin
and varargout parameters to the
argument list of a class method.

Describes the Visual Basic exception
handling capability.

Describes array formattingand data
conversion flags.
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Overview

Each MATLAB Builder for Excel component is built as a stand-alone COM
object. You access a component from Microsoft Excel through Visual Basic
for Applications (VBA). This section provides general information on how to
integrate Excel Builder components into Excel using the VBA programming
environment. It assumes that you have a working knowledge of VBA and is
not intended to be a discussion on how to program in Visual Basic. Refer
to the VBA documentation provided with Excel for general programming
information.

You can easily integrate Excel Builder components into a VBA project by
creating a simple code module with functions and/or subroutines that load
the necessary components, call methods as needed, and process any errors.
In general, you need to address seven items in any code written to use Excel
Builder components:

® “When to Use a Formula Function or a Subroutine” on page 3-3

e “Initializing MATLAB Builder for Excel Libraries with Excel” on page 3-4
® “Creating an Instance of a Class” on page 3-6

e “Calling the Methods of a Class Instance” on page 3-9

® “Processing varargin and varargout Arguments” on page 3-11

¢ “Handling Errors During a Method Call” on page 3-13

* “Modifying Flags” on page 3-14

Note All code samples in this section are for illustration purposes and
reference a hypothetical class named myclass contained in a component
named mycomponent with a version number of 1.0.

For a list of working code examples, go to.the product page for MATLAB
Builder for Excel and click the Examples in Documentation target.



http://www.mathworks.com/access/helpdesk/help/toolbox/matlabxl/

When to Use a Formula Function or a Subroutine

When to Use a Formula Function or a Subroutine

VBA provides two basic procedure types, functions and subroutines. You
access a VBA function directly from a cell in a worksheet as a formula
function and access a subroutine as a general macro. Function procedures
are useful when the original MATLAB function takes one or more inputs and
returns one scalar output. When the original MATLAB function returns an
array of values or multiple outputs, you need a subroutine procedure to map
these outputs into multiple cells/ranges in the worksheet. When you create
a MATLAB Builder for Excel component, you produce a VBA module (.bas
file). This file contains simple call wrappers, each implemented as a function
procedure for each method of the class.
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Initializing MATLAB Builder for Excel Libraries with Excel

Before you use any MATLAB Builder for Excel component, initialize the
supporting libraries with the current instance of Excel. Do this once for an
Excel session that uses Excel Builder components. To do this initialization,
call the utility library function MWInitApplication, a member of the MWUtil
class. This class is part of the MWComUtil library. See the section “Utility
Library Classes” on page C-3 for a detailed discussion of the functionality
provided with this library.

One way to add this initialization code into a VBA module is to provide

a subroutine that does the initialization once, and simply exits for all
subsequent calls. The following Visual Basic code sample initializes the
libraries with the current instance of Excel. A global variable of type Object
named MCLUtil holds an instance of the MWUtil class, and another global
variable of type Boolean named bModuleInitialized stores the status of
the initialization process. The private subroutine InitModule () creates

an instance of the MWComUtil class and calls the MWInitApplication
method with an argument of Application. Once this function succeeds, all
subsequent calls exit without reinitializing.

Dim MCLUtil As Object
Dim bModuleInitialized As Boolean

Private Sub InitModule()
If Not bModuleInitialized Then
On Error GoTo Handle Error
If MCLUtil Is Nothing Then
Set MCLUtil = CreateObject("MWComUtil.MWUtil")
End If
Call MCLUtil.MWInitApplication(Application)
bModuleInitialized = True
Exit Sub
Handle_Error:
bModuleInitialized = False
End If
End Sub

This code is similar to the default initialization code generated in the VBA
module created when the component is built. Each function that uses Excel
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Builder components can include a call to InitModule at the beginning to
ensure that the initialization always gets performed as needed.
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Creating an Instance of a Class

Before calling a class method (compiled MATLAB function), you must
create an instance of the class that contains the method. VBA provides two
techniques for doing this:

® CreateObject function

® Visual Basic New operator

CreateObiject Function

This method uses the Visual Basic application program interface (API)
CreateObject function to create an instance of the class. To use this method,
Dim a variable of type Object to hold a reference to the class instance and
call CreateObject using the class programmatic identifier (ProgID) as an
argument, as shown in the next example.

Function foo(x1 As Variant, x2 As Variant) As Variant
Dim aClass As Object

On Error Goto Handle_Error
aClass = CreateObject("mycomponent.myclass.1_0")
" (call some methods on aClass)
Exit Function
Handle_Error:
foo = Err.Description
End Function

Visual Basic New Operator

This method uses the Visual Basic New operator on a variable explicitly
dimensioned as the class to be created. Before using this method, you must
reference the type library containing the class in the current VBA project.
Do this by selecting the Tools menu from the Visual Basic editor, and then
selecting References to display the Available References list. From this
list select the necessary type library.

The following example illustrates using the New operator to create a class

instance. It assumes that you have selected mycomponent 1.0 Type
Library from the Available References list before calling this function.
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Function foo(x1 As Variant, x2 As Variant) As Variant
Dim aClass As mycomponent.myclass

On Error Goto Handle_Error
Set aClass = New mycomponent.myclass
" (call some methods on aClass)
Exit Function
Handle_Error:
foo = Err.Description
End Function

In this example, the class instance could be dimensioned as simply myclass.
The full declaration in the form <component-name>.<class-name> guards
against name collisions that could occur if other libraries in the current
project contain types named myclass.

Both methods are equivalent in functionality. The first method does not
require a reference to the type library in the VBA project, while the second
results in faster code execution. The second method has the added advantage
of enabling the Auto-List-Members and Auto-Quick-Info capabilities of
the VBA editor to work with your classes. The default function wrappers
created with each built component all use the first method for object creation.

In the previous two examples, the class instance used to make the method
call was a local variable of the procedure. This creates and destroys a new
class instance for each call. An alternative approach is to declare one single
module-scoped class instance that is reused by all function calls, as in the
initialization code of the previous example.

The following example illustrates this technique with the second method.

Dim aClass As mycomponent.myclass

Function foo(x1 As Variant, x2 As Variant) As Variant
On Error Goto Handle_Error
If aClass Is Nothing Then
Set aClass = New mycomponent.myclass
End If
" (call some methods on aClass)
Exit Function
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Handle_Error:
foo = Err.Description
End Function
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Calling the Methods of a Class Instance

After you have created a class instance, you can call the class methods to
access the compiled MATLAB functions. MATLAB Builder for Excel applies a
standard mapping from the original MATLAB function syntax to the method’s
argument list. See section “Calling Conventions” on page A-12 for a detailed
description of the mapping from MATLAB functions to COM class method
calls.

When a method has output arguments, the first argument is always nargout,
which is of type Long. This input parameter passes the normal MATLAB
nargout parameter to the compiled function and specifies how many outputs
are requested. Methods that do not have output arguments do not pass

a nargout argument. Following nargout are the output parameters listed

in the same order as they appear on the left side of the original MATLAB
function. Next come the input parameters listed in the same order as they
appear on the right side of the original MATLAB function. All input and
output arguments are typed as Variant, the default Visual Basic data type.

The Variant type can hold any of the basic VBA types, arrays of any type,
and object references. See “Data Conversion Rules” on page B-2 for a detailed
description of how to convert Variants of any basic type to and from MATLAB
data types. In general, you can supply any Visual Basic type as an argument
to a class method, with the exception of Visual Basic UDTs. You can also pass
Excel Range objects directly as input and output arguments.

When you pass a simple Variant type as an output parameter, the called
method allocates the received data and frees the original contents of the
Variant. In this case it is sufficient to dimension each output argument as
a single Variant. When an object type (like an Excel Range) is passed as an
output parameter, the object reference is passed in both directions, and the
object’s Value property receives the data.

The following examples illustrate the process of passing input and output
parameters from VBA to Excel Builder component class methods.

The first example is a formula function that takes two inputs and returns one

output. This function dispatches the call to a class method that corresponds to
a MATLAB function of the form function y = foo(x1,x2).
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Function foo(x1 As Variant, x2 As Variant) As Variant
Dim aClass As Object
Dim y As Variant

On Error Goto Handle_Error
aClass = CreateObject("mycomponent.myclass.1_0")
Call aClass.foo(1,y,x1,x2)
foo =y
Exit Function
Handle_Error:
foo = Err.Description
End Function

The second example rewrites the same function as a subroutine and uses
Excel ranges for input and output.

Sub foo(Rout As Range, Rin1 As Range, Rin2 As Range)
Dim aClass As Object

On Error Goto Handle_Error
aClass = CreateObject("mycomponent.myclass.1_0")
Call aClass.foo(1,Rout,Rin1,Rin2)
Exit Sub
Handle_Error:
MsgBox (Err.Description)
End Sub



Processing varargin and varargout Arguments

Processing varargin and varargout Arguments

When varargin and/or varargout are present in the MATLAB function that
you are using for the Excel component, these parameters are added to the
argument list of the class method as the last input/output parameters in the
list. You can pass multiple arguments as a varargin array by creating a
Variant array, assigning each element of the array to the respective input
argument.

The following example creates a varargin array to call a method resulting
from a MATLAB function of the form y = foo(varargin).

Function foo(x1 As Variant, x2 As Variant, x3 As Varaint, _
x4 As Variant, x5 As Variant) As Variant
Dim aClass As Object
Dim v(1 To 5) As Variant
Dim y As Variant

On Error Goto Handle Error

v(1) = x1
v(2) = x2
v(3) = x3
v(4) = x4
v(5) = x5

aClass = CreateObject("mycomponent.myclass.1_0")
Call aClass.foo(1,y,V)
foo =y
Exit Function
Handle_Error:
foo = Err.Description
End Function

The MWUtil class included in the MWComUtil utility library provides the
MWPack helper function to create varargin parameters. See “Utility Library
Classes” on page C-3 for more details.

The next example processes a varargout parameter into three separate Excel

Ranges. This function makes use of the MWUnpack function in the utility
library. The MATLAB function used is varargout = foo(x1,x2).
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Sub foo(Rout1 As Range, Rout2 As Range, Rout3 As Range, _

Rin1 As Range, Rin2 As Range)
Dim aClass As Object
Dim auUtil As Object
Dim v As Variant

On Error Goto Handle_Error

aUtil = CreateObject("MWComUtil.MWUtil")

aClass = CreateObject("mycomponent.myclass.1_0")
Call aClass.foo(3,v,Rin1,Rin2)

Call auUtil.MwUnpack(v,0,True,Rout1,Rout2,Rout3)
Exit Sub

Handle_Error:

MsgBox (Err.Description)

End Sub



Handling Errors During a Method Calll

Handling Errors During a Method Call

Errors that occur while creating a class instance or during a class method
create an exception in the current procedure. Visual Basic provides

an exception handling capability through the On Error Goto <label>
statement, in which the program execution jumps to <label> when an error
occurs. (<label> must be located in the same procedure as the On Error
Goto statement). All errors are handled this way, including errors within
the original MATLAB code. An exception creates a Visual Basic ErrObject
object in the current context in a variable called Err. (See the Visual Basic for
Applications documentation for a detailed discussion on VBA error handling.)
All of the examples in this section illustrate the typical error trapping logic
used in function call wrappers for MATLAB Builder for Excel components.
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Modifying Flags

Each MATLAB Builder for Excel component exposes a single read/write
property named MWFlags of type MWFlags. The MWFlags property consists of
two sets of constants: array formatting flags and data conversion flags. Array
formatting flags affect the transformation of arrays, whereas data conversion
flags deal with type conversions of individual array elements.

The data conversion flags change selected behaviors of the data conversion
process from Variants to MATLAB types and vice versa. By default, Excel
Builder components allow setting data conversion flags at the class level
through the MWFlags class property. This holds true for all Visual Basic
types, with the exception of the Excel Builder MWStruct, MWField, MWComplex,
MWSparse, and MWArg types. Each of these types exposes its own MWFlags
property and ignores the properties of the class whose method is being
called. The MWArg class is supplied specifically for the case when a particular
argument needs different settings from the default class properties.

This section provides a general discussion of how to set these flags and what
they do. See “Class MWFlags” on page C-10 for a detailed discussion of the
MWFlags type, as well as additional code samples.

Array Formatting Flags

Array formatting flags guide the data conversion to produce either a MATLAB
cell array or matrix from general Variant data on input or to produce an array
of Variants or a single Variant containing an array of a basic type on output.

The following examples assume that you have referenced the MWComUtil
library in the current project by selecting Tools > References and selecting
MWComUtil 1.0 Type Library from the list.

Sub foo( )
Dim aClass As mycomponent.myclass
Dim var1(1 To 2, 1 To 2), var2 As Variant
Dim x(1 To 2, 1 To 2) As Double
Dim y1,y2 As Variant

On Error Goto Handle Error
var1(1,1) = 11#
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vari(1,2) = 12#
vari(2,1) = 21#
vari(2,2) = 22#
x(1,1) = 11

x(1,2) = 12
x(2,1) = 21
X(2,2) = 22
var2 = X

Set aClass = New mycomponent.myclass
Call aClass.foo(1,y1,vart)
Call aClass.foo(1,y2,var2)
Exit Sub
Handle_Error:
MsgBox (Err.Description)
End Sub

Here, two Variant variables, var1 and var2 are constructed with the same
numerical data, but internally they are structured differently. var1 is a 2-by-2
array of Variants with each element containing a 1-by-1 Double, while var2
is a 1-by-1 Variant containing a 2-by-2 array of Doubles. According to the
default data conversion rules listed in , var1 converts to a 2-by-2 cell array
with each cell occupied by a 1-by-1 double, and var2 converts directly to a
2-by-2 double matrix. The InputArrayFormat flag controls how arrays of
these two types are handled. As it turns out, the two arrays in the previous
example both convert to double matrices because the default value for the
InputArrayFormat flag is mwArrayFormatMatrix. This default is used
because, as it turns out, array data originating from Excel ranges is always
in the form of an array of Variants (like var1 of the previous example), and
MATLAB functions most often deal with matrix arguments. But what if you
really want a cell array? In this case, you set the InputArrayFormat flag

to mvArrayFormatCell. Do this by adding the following line after creating
the class and before the method call.

aClass .MWFlags.ArrayFormatFlags.InputArrayFormat =
mwArrayFormatCell

Setting this flag presents all array input to the compiled MATLAB function as
cell arrays.
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Similarly, you can manipulate the format of output arguments using the
OutputArrayFormat flag. You can also modify array output with the
AutoResizeOutput and TransposeOutput flags.

AutoResizeOutput is used for Excel Range objects passed directly as output
parameters. When this flag is set, the target range automatically resizes to fit
the resulting array. If this flag is not set, the target range must be at least as
large as the output array or the data is truncated.

The TransposeOutput flag transposes all array output. This flag is useful
when dealing with MATLAB functions that output one-dimensional arrays.
By default, MATLAB realizes one-dimensional arrays as 1-by-n matrices (row
vectors) that become rows in an Excel worksheet.

You may prefer worksheet columns from row vector output. This example
auto-resizes and transposes an output range.

Sub foo(Rout As Range, Rin As Range )
Dim aClass As mycomponent.myclass

On Error Goto Handle_Error
Set aClass = New mycomponent.myclass
aClass.MWFlags.ArrayFormatFlags.AutoResizeQutput = True
aClass.MWFlags.ArrayFormatFlags.TransposeOutput = True
Call aClass.foo(1,Rout,Rin)
Exit Sub

Handle_Error:
MsgBox (Err.Description)

End Sub

Data Conversion Flags

Data conversion flags deal with type conversions of individual array elements.
The two data conversion flags, CoerceNumericToType and InputDateFormat,
govern how numeric and date types are converted from VBA to MATLAB.
Consider the example

Sub foo( )
Dim aClass As mycomponent.myclass
Dim var1, var2 As Variant
Dim y As Variant
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On Error Goto Handle_Error
var1l = 1
var2 = 2#
Set aClass = New mycomponent.myclass
Call aClass.foo(1,y,var1,var2)
Exit Sub
Handle_Error:
MsgBox (Err.Description)
End Sub

This example converts var1 of type Variant/Integer to an int16 and var2 of
type Variant/Double to a double. If the original MATLAB function expects
doubles for both arguments, this code might cause an error. One solution is to
assign a double to var1, but this may not be possible or desirable. In such a
case set the CoerceNumericToType flag to mwTypeDouble, causing the data
converter to convert all numeric input to double. In the previous example,
place the following line after creating the class and before calling the methods.

aClass .MWFlags.DataConversionFlags.CoerceNumericToType =
mwTypeDouble

The InputDateFormat flag controls how the VBA Date type is converted.
This example sends the current date and time as an input argument and
converts it to a string.

Sub foo( )
Dim aClass As mycomponent.myclass
Dim today As Date
Dim y As Variant

On Error Goto Handle_Error

today = Now

Set aClass = New mycomponent.myclass

aClass. MWFlags.DataConversionFlags.InputDateFormat =
mwDateFormatString

Call aClass.foo(1,y,today)

Exit Sub
Handle_Error:

MsgBox (Err.Description)
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End Sub

The next example uses an MWArg object to modify the conversion flags for
one argument in a method call. In this case the first output argument (y1)
is coerced to a Date, and the second output argument (y2) uses the current
default conversion flags supplied by aClass.

Sub foo(y1l As Variant, y2 As Variant)
Dim aClass As mycomponent.myclass
Dim ytemp As MWArg
Dim today As Date

On Error Goto Handle_Error

today = Now

Set aClass = New mycomponent.myclass
Set y1 = New MWArg
y1.MWFlags.DataConversionFlags.OutputAsDate = True
Call aClass.foo(2, ytemp, y2, today)
y1 = ytemp.Value

Exit Sub

Handle_Error:

MsgBox (Err.Description)

End Sub
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Magic Square Examples (p. 4-2)

Using Multiple Files and Variable
Arguments (p. 4-8)

Spectral Analysis Example (p. 4-17)

Creates a magic square from a single
input integer.

Plots a line from 1 to an input
number.

Creates a comprehensive Excel
add-in to perform spectral analysis.
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Magic Square Examples

The M-file mymagic takes a single input, an integer, and creates a magic
square of that size.

The Excel file mymagic.x1s uses this function in three different ways:

® The first illustration calls the function mymagic with a value of 4. The
function returns a magic square of size 4 and populates a range of Excel
cells with that magic square.

® The second illustration uses the transpose flag to transpose a magic square
of size 4.

® The third illustration resizes the output to a higher value and moves its
location within the Excel worksheet.

Note To get started, copy the distributed directory x1magic from
<matlab>\toolbox\matlabxl\examples\xlmagic to <matlab>\work.

Creating the Project

From the MATLAB command, prompt change directories to <matlab>\work.
Enter the command mx1tool to start the MATLAB Builder window. From the
File menu, select New Project. This opens the New Project Settings dialog.



Magic Square Examples

«): New Project Settings 10l =|
rProject naming

Component name

Classes

Class name

I Add ==
Remaove

Froject version

Froject directary

Erowse... |

rCompiler aption

[ Creste s singleton MCR
™ Build debug version

[ Show verbose output

Ok | Cancel | Help |

Empty New Project Settings Dialog Box

On the New Project Settings dialog, enter the settings as listed below.

In the Component name text block enter the component name x1lmagic.
Press the Tab key to move to the Class name text block.

This automatically fills in the Classes field with the name x1magicclass.
Leave this text in the Classes field.

The version has a default of 1.0. Leave this version as is.

The Project directory field contains a default of a combination of the
directory where MATLAB Builder for Excel was started, <matlab>\work,
and the Component name, x1magic. You can change this to any directory
that you choose. If the directory you choose does not exist, you will be
asked to create it.

Leave all Compiler options unselected.

The New Project Settings dialog now appears as shown.:.
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« ):New Project Settings

=10l x|

rProject naming

Component name

Imagic
Classes

Class name

l Add ==
Remaove

Froject version

lmagicclass

|10

Froject directary

lD:IworKLxImagic

Erowse... |

rCompiler aption
[~ Creste s singleton MCR
I~ Build debug version

™ Show verbose output

Ok | Cancel | Help

New Project Settings with Entries

® (Click OK to create the x1magic project.

Summary of Project Settings
Component name: xlmagic

Class name: xlmagicclass

Project version: 1.0

Project directory: (accept default or choose another directory)

Compiler options: (leave unselected)

Building the Project

® On the MATLAB Builder window, click the Add File button.
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® Select the file mymagic.m from the directory <matlab>\work\x1lmagic and
click Open.

¢ Select Excel/COM Object from the Build menu.

Adding the Excel Builder COM Function to Excel

e Start Excel on your system.

® Open the file <matlab>\work\x1lmagic\mymagic.x1s.

Note If you receive an Excel prompt informing you that this file contains
macros, select the Enable Macros option to run this example.

lllustration 1. Output Magic Square Results to Excel
From the main Excel window (not the Visual Basic editor), display the Macro
dialog either by selecting the Alt and F8 keys at the same time or by selecting
the Macros option from Tools > Macro.

Select mymagic from the list and click Run. This procedure returns a magic
square of size 4 beginning in cell B2.

A [ 8 [ ¢ [ b [ E [ F |
4 16 2 3 13
5 11 10 B
g 7 B 12
4 14 15 1

The above example runs the macro "mymagic” which
populates the cells B2 through ES with a magic square of 4
Select Tools-=Macro-= Macros to run this example

Magic Square Returned to Excel Worksheet

lllustration 2. Transpose the Output

Reopen the Macro dialog, select the mymagic transpose macro and click the
Run button. This procedure returns a magic square of size 4 transposed,
beginning in cell B14.
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113
| 14 | 4 16 a 4
| 15 | 2 7 14
| 16 | 3 10 G

17 13 g 12
| 18 |
| 19 |The above example runs the macro "mymagic_transpose” which
| 20 |transposes the results of a magic square of 4 and populates the
| 21 |cells B14 through E17

22 |Select Tools-=Macro-> Macros to run this example

Transposed Magic Square

lllustration 3. Resize the Output

Reopen the Macro dialog, select the mymagic resize macro, and click Run.
This procedure returns a magic square of size 4 beginning in cell B32.

Change the value of 4 in cell A32 to a higher value and rerun this macro. A
magic square of the size you specified in cell A32 is returned, beginning in

cell B32.
| 27 |The below example runs the macro "mymagic_resize” which
| 28 |has an initial range far a magic square of 4 but will resize if
| 25 |the output is larger. Gradually increase the number in cell A32 and rerun the macra.
| 30 |CAUTION: Resizing will aver write any existing data in the target cells
Ell
32 g1 64 2 3 61 G0 G 7 571
133 | { a 55 54 12 13 a1 50 16!
| 34 | 1 17 47 45 20 21 43 42 24
| 35 | | 40 2 2 7 35 30 Kl 33l
| 36 | : 32 34 35 2 28 =] ] 25
| 37 | 1 41 23 2 44 45 19 18 481
El ! 48 15 14 52 53 11 10 56
El | ____B___®____ 5 ____ E____A____ B2 ___®8____1
40

Resized Magic Square

Inspecting the Visual Basic Code

On the Excel main window select Visual Basic Editor from the
Tools > Macro menu.

From the Visual Basic editor, in the Project - VBAProject window, double-click
to expand the project VBAProject (mymagic.xls).

Expand the Modules folder and double-click on the Module1 module. This
opens the VB Code window with the code for this project, as shown:
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Examples

Edit Wew Insert Format Debug Run Tools Add-dns iindow Help

C@ LR o o o1 ek NEE 20 -

2=l

Madule1 (Code)

ac [T xla)
8 Excllink (excllink.xla)
% VBAProject (mymagic.xla)
£ & vBAProject (mymagic.xls)
£ 5 Microsoft Excel Objects
£ sheet] (Magic Square Example)
3] Thisworkbook
£ 55 Modules
o Modulet

Dim MCLUEil is Object
Dim hModuleInitialized hs Boolean

Private Sub InitModule()
If Not bModuleInitialized Then
On Error GoTo Handle Error
If NCLUeil Is Nothing Then
Ser MCLUEil = CreateOhject ("MUComUtil.MUUti
End If
Call BCLUEil.MUInicipplicacion(ipplication!
bModulelnitialized = True
Exit Sub
Hendle Error:
bModuleInitialized = False
End If
End Sub
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Using Multiple Files and Variable Arguments

The M-file, myplot, takes a single integer input and plots a line from 1 to
that number.

The M-file, mysum, takes an input of varargin of type integer, adds all the
numbers, and returns the result.

The M-file, myprimes, takes a single integer input n and returns all the prime
numbers less than or equal to n.

The Microsoft Excel file, mymulti.xls, demonstrates these functions in a
multiple of ways.

Note To get started copy the distributed directory x1lmulti from
<matlab>\toolbox\matlabxl\examples\x1lmulti to <matlab>\work.

Creating the Project

From the MATLAB command prompt, change directories to <matlab>\work.
Enter the command mx1tool to start the MATLAB Builder window. From the
File menu select New Project. This opens the New Project Settings dialog
box.
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«): New Project Settings 10l =|
rProject naming

Component name

Classes

Class name

I Add ==
Remaove

Froject version

Froject directary

Erowse... |

rCompiler aption
[ Creste s singleton MCR
™ Build debug version

[ Show verbose output

Ok | Cancel | Help |

Empty New Project Settings Dialog
On the New Project Settings dialog, enter the settings as listed below.
¢ In the Component name text block enter the component name x1multi.

Press the Tab key to move to the Class name text block.

® This automatically fills in the Classes field with the name x1multiclass.
Leave this text in the Classes field.

e The version has a default of 1.0. Leave this version as is.

® The Project directory field contains a default of a combination of the
directory where Excel Builder was started, <matlab>\work, and the
Component name, x1multi. You can change this to any directory that
you choose. If the directory you choose does not exist, you will be asked
to create it.

® Leave all other Compiler options unselected.

The New Project Settings dialog now appears as shown:
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= ):New Project Settings
rProject k ng

=10l x|

Component name

lemulti

Class name

l Add ==
Remaove

Froject version

Classes

multiclass

|10

Froject directary

|Dworkidmulti

Erowse... |

rCompiler aption

[~ Creste s singleton MCR
I~ Build debug version

™ Show verbose output

Ok | Cancel

| Help |

® (Click OK to create the x1multi project.

Summary of Project Settings
Component name: x1lmulti

Class name: x1lmulti

Project version:

Project directory: (accept default or choose another directory)

Compiler option

Building the

¢ On the MATLAB Builder window click Add File .
® Select the file myplot.m from the directory <matlab>\work\x1lmulti and

click Open.

1.0

s: (leave unselected)

Project



Using Multiple Files and Variable Arguments

® Repeat the above steps to add the files myprimes.m and mysum.m.
* Select Excel/COM Object from the Build menu.

Adding Excel Builder COM Functions to Excel

e Start Excel on your system.

® Open the file <matlab>\work\x1multi\mymulti.x1ls.

Note If you receive an Excel prompt informing you that this file contains
macros, select the Enable Macros option to run this example.

4-11
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A B c D E F G H | J

1 1

Sample: myplot

In this simple example we are just plotting a line from 1 to whatever
number is supplied as an argument to the function in cell A7,

a

Sample: mysum

In the below example we are just adding up a series of numbers that
are explicitly stated.
55

In the below example we are just adding up a series of numbers that
are frorm a range of cells.
55 1 2 3 4 ] G 7 g a

In the below example, we are adding up 3 separate ranges of cells.
The ranges do not need to be the same size nor do all the cells in the range need to have data in them.

120 1 2 3 4 a 5] 7 g 9
1 2 3 4 a 5] g 9
1 2 3

In the below example, we are adding 10 to a range of cells.
16 1 2 3

Sample: myprimes

(SRR L] [NUESNUE NSNS O S S S el Bl Bl vl Bl el el el ==t

[¥x}
(a3}

EThe below example runs the macro "myprimes" which

| 38 |has an initial range far 4 prime numbers bot will resize if

| 35 |the output is larger. Gradually increase the number in cell A42 and rerun the macra.
| 40 |CAUTION: Resizing will aver write any existing data in the target cells

11 N USRIV PRI SV R
22 B N A J
mymulti.xls

lllustration 4: Calling myplot

This illustration calls the function myplot with a value of 4. To execute the
function, make A7 the active cell. Press F2 and then Enter.
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Bl xlmultixls
A B c D E F G

Sample: myplot

In this simple example we are just plotting a line from 1 to whatever
number is supplied as an argurent to the function in cell A7,

ol

C_alling myplot with a Value of 4

This procedure plots a line from 1 to 4 in a MATLAB figure window. This
graphic can be manipulated as if it were called from MATLAB directly. The
calling cell contains 0 because the function does not return a value.

<) Figure No. 1 10l =|

File Edit Yiew Insert Tools Window Help

Insda/ "ar/|®2p0

4

myplot Output

lllustration 5: Calling mysum Four Different Ways

This illustration calls the function mysum in four different ways. The first
(cell A14) takes the values 1 through 10, adds them, and returns the result
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of 55. The second (cell A19) takes a range object that is a range of cells with
the values 1 through 10, adds them, and returns the result of 55. The third
(cell A24) takes several range objects, adds them, and returns the result of
120. This illustration demonstrates that the ranges do not need to be the
same size and that all the cells do not have to have a value. The fourth
(cell A30) takes a combination of a range object and explicitly stated values,
adds them, and returns the result of 16.

[}

Sample: mysum

In the below example we are just adding up a series of numbers that
are explicitly stated.
55

~a

a1}

=

o

o

~

In the below example we are just adding up a series of numbers that
are frorm a range of cells.

[}

119 | 55 1 2 3 4 ] G 7 g a 10
120 |

121 |

|22 |In the below example, we are adding up 3 separate ranges of cells.

|23 | The ranges do nat need to be the same size nor do all the cells in the range need to have data in them.

124 | 120 1 2 3 4 ] G 7 g a 10
125 | 1 2 3 4 ] G g a 10
126 | 1 2 3

127 |

128 |

29 |In the below example, we are adding 10 to a range of cells.

30 161 1 2 3

21

Four Different Calls fo mysum

This illustration runs when the Excel file is opened. To reactivate the
illustration, make the appropriate cell active. Then press F2 followed by
Enter.

lllustration 6: myprimes Macro

In this illustration the macro myprimes calls the function myprimes.m with an
initial value of 10 in cell A42. The function returns all the prime numbers
less than 10 to cells B42 through E42.

11
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3
35|
36|
57 |
38
39|
140
41

=

42

Sample: myprimes

The below example runs the macro "myprimes" which

has an initial range for 4 prime numbers but will resize if

the output is larger. Gradually increase the number in cell A42 and rerun the macro.
CAUTION: Resizing will over write any existing data in the target cells

myprimes Macro

To

execute the macro, from the main Excel window (not the Visual Basic

editor), display the Macro dialog either by selecting the Alt and F8 keys at
the same time or by selecting the Macros option from Tools > Macro.

Select myprimes from the list and click Run.

x Sample: myprimes

35

36

_37 |The below example runs the macro "myprimes” which

38 |has an initial range far 4 prime numbers bot will resize if

35 |the output is larger. Gradually increase the number in cell A42 and rerun the macra.
(40 | CAUTION: Resizing will aver write any existing data in the target cells

41

72 [ SN SO I e i

43

myprimes Output for Value of 10

This function automatically resizes if the returned output is larger than the
output range specified. Change the value in cell A42 to a number larger than
10. Then rerun the macro. The output returns all prime numbers less than
the number you entered in cell A42.
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3
| 35 |
| 36 |
| 37 |The helow example runs the macro "myprimes” which

| 38 |has an initial range far 4 prime numbers bot will resize if

| 35 |the output is larger. Gradually increase the number in cell A42 and rerun the macra.
| 40 | CAUTION: Resizing will over write any existing data in the target cells

=

Sample: myprimes

41
42| P A - B 7 11 13 17 19

myprimes Output for Value > 10
Inspecting the Visual Basic Code
From Excel select Visual Basic Editor from the Tools > Macro menu.

From the Visual Basic editor, in the Project - VBAProject window, expand the
project VBAProject (mymulti.xls).

Expand the Modules folder and double-click on the Module1 module. This
opens the VB Code window with the code for this project, as shown:

£ Microsoft Yisual Basic - slmulti.xls

JEiIe Edit Yiew Insert Format Debug Run Tools Add-Ins Window Help
[HaE- 8 ema o o]y ) akd HEE | D n,
Project - ¥BAProject k3 simulti.xls - Modulel (Code)
”E | I(General}

EI@ AcrobatPDFWriter {PDFWriter.xla)
[-[77] Microsaft Excel Objects

Dim MCLUtil As Chject

=5 Modules Dim bModuleInitialized is Eoolean
%83 ButoExec
~wdl AutoExit Private Sub InitModule ()
%8} DistMan If Not bModuleInitialized Then
-4 IniFiles On Error GoTo Handle Error
ol Re_gistfatiﬂnDatabase If MCLUtil Is Nothing Then
o8 Strings Set MCLUtil = CreateChject ("MUCowUtil.MWUtilt
[]---@ Excllink {excllink.xla}) End If

=& vBAProject (xImulti.xls) Call MCLUEil.MWInitipplication(ipplication)

bModuleInitialized = True
Sheetl (Sheetl) Exit Sub

Sheetz (Sheetz) Handle Error:
- Sheet3 (Sheet3) bModuleInitialized = False
: @ Thisworkbook, End If

Modules End Sub




Spectral Analysis Example

Spectral Analysis Example

This example illustrates the creation of a comprehensive Excel add-in to
perform spectral analysis. It requires knowledge of Visual Basic forms and
controls, as well as Excel workbook events. See the VBA documentation for a
complete discussion of these topics.

The example creates an Excel add-in that performs a fast Fourier transform
(FFT) on an input data set located in a designated worksheet range. The
function returns the FFT results, an array of frequency points, and the power
spectral density of the input data. It places these results into ranges you
indicate in the current worksheet. You can also optionally plot the power
spectral density. You develop the function so that you can invoke it from the
Excel Tools menu and can select input and output ranges through a GUL.

To create this add-in requires four basic steps:

1 Build a stand-alone COM component from MATLAB code.

2 Implement the necessary VBA code to collect input and dispatch the calls
to your component.

3 Create the GUI.

4 Create an Excel add-in and package all necessary components for
application deployment.

Building the Component

Your component will have one class with two methods, computefft and
plotfft. The computefft method computes the FFT and power spectral
density of the input data and computes a vector of frequency points based
on the length of the data entered and the sampling interval. The plotfft
method performs the same operations as computefft, but also plots the
input data and the power spectral density in a MATLAB figure window. The
MATLAB code for these two methods resides in two M-files, computefft.m
and plotfft.m.

computefft.m:
function [fftdata, freq, powerspect] = computefft(data, interval)
if (isempty(data))
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fftdata = [];
freq = [];
powerspect = [];
return;
end
if (interval <= 0)
error('Sampling interval must be greater then zero');
return;
end
fftdata = fft(data);
freq = (0:length(fftdata)-1)/(length(fftdata)*interval);
powerspect = abs(fftdata)/(sqrt(length(fftdata)));
plotfft.m:

function [fftdata, freq, powerspect] = plotfft(data, interval)
[fftdata, freq, powerspect] = computefft(data, interval);
len = length(fftdata);
if (len <= 0)
return;
end
t = O:interval:(len-1)*interval;
subplot(2,1,1), plot(t, data)
xlabel('Time'), grid on
title('Time domain signal')
subplot(2,1,2), plot(freq(1:1len/2), powerspect(1:1len/2))
xlabel('Frequency (Hz)'), grid on
title('Power spectral density')

To proceed with the actual building of the component, follow these steps:

Start mx1tool. See “Graphical User Interface Menus” on page 2-2 for a
discussion of using mx1tool to build a COM component from a collection
of MATLAB M-files.

Create a new project with these settings:

Component name: Fourier
Class name: Fourier

Project version: 1.0
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Add the computefft.m and plotfft.m M-files to the project.

1 Save the project. Make note of the project directory because you will refer
to it later when you save your add-in.

2 Click Build to create the component.

Integrating the Component with Visual Basic for
Applications

Having built your component, you can implement the necessary VBA code
to integrate it into Excel. Follow these steps to open Excel and select the
libraries you need to develop the add-in.

1 Start Excel.
2 From the Excel main menu, select Tools>Macro>Visual Basic Editor.

3 When the Visual Basic editor starts, select Tools>References to display
the Project References dialog. Select Fourier 1.0 Type Library and
MWComUtil 7.1 Type Library from the list.

Creating the Main VB Code Module for the Application

The add-in requires some initialization code and some global variables to
hold the application’s state between function invocations. To achieve this,
implement a Visual Basic code module to manage these tasks, as follows:

1 Right-click on the VBAProject item in the project window and select
Insert>Module from the pop-up menu.

2 A new module appears under Modules in the VBA Project. In the
module’s property page, set the Name property to FourierMain. See the
next figure.
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@i Microsoft Yisual Basic - Fourier.xls - [FourierMain (Code)] =)
| Eie Edit Yew Insert Formst Debug Run ook addIns Window Help _i& 5||
|Ha-R s eeam oo, alBEsyg2 g .

2=l

[=-&% vBAPraject (Fourier.xls)
o saft Excel Objects

-8 Thisorkbook

I(Generil)

| I(D:clirilinns)

' FourierHMain - Hain woduls Stores global State of controls
't oand provides initialization cods

'Global instance of Fouriler ohject
Public theFourier As Fourier.Fourier
'Global instance of NWComplex to accept FFT of input rangs

-2 Forms

Public theFFTData s MUComplex
(=23 Modules ' Input data range
R 4 ourrilan Public InputData As Range

'Sampling interval
Public Interval is Double

‘Output frequency data range

Public Frequency Ls Range

‘Output power spectral density range

Public PowerSpect is Rangs

'Haolds the state of plot flag

Public bPlot is Boolean

'Global instance of MUUril chieet

Public theltil is NUUtil

"Madule-is-initialized flag

Public bInitialized is Boolean

Private Sub LoadFourier ()

'Initializes globals and Loads the Spectral inalysis form

Properties - Fourier
[FourierMain module
Alphabetic ICatagurizad |

Ll i

2 FourierMain

Locals

[<Ready=

Expression [vaive [ Type

Ll

VBA Project: Inserting the Module

3 Enter the following code in the FourierMain module:

FourierMain - Main module stores global state of controls

and provides initialization code

Public theFourier As Fourier.Fourier 'Global instance of Fourier object
Public theFFTData As MWComplex
Public InputData As Range
Public Interval As Double
Public Frequency As Range

'Global instance of MWComplex to accept FFT
'Input data range

'Sampling interval

'Output frequency data range

Public PowerSpect As Range
Public bPlot As Boolean

Public theUtil As MWUtil
Public bInitialized As Boolean

'Output power spectral density range
'Holds the state of plot flag
'Global instance of MWUtil object
'Module-is-initialized flag

Private Sub LoadFourier()
'Initializes globals and Loads the Spectral Analysis form
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Dim MainForm As frmFourier

On Error GoTo Handle_Error
Call InitApp

Set MainForm = New frmFourier
Call MainForm.Show

Exit Sub

Handle_Error:

MsgBox (Err.Description)

End Sub

Private Sub InitApp()
'Initializes classes and libraries. Executes once
'for a given session of Excel

If bInitialized Then Exit Sub
On Error GoTo Handle_Error
If theUtil Is Nothing Then
Set theUtil = New MWUtil
Call theUtil.MWInitApplication(Application)
End If
If theFourier Is Nothing Then
Set theFourier = New Fourier.Fourier
End If
If theFFTData Is Nothing Then
Set theFFTData = New MWComplex
End If
bInitialized = True
Exit Sub

Handle_Error:

MsgBox (Err.Description)

End Sub

Creating the Visual Basic Form

The next step in the integration process develops a user interface for your
add-in using the Visual Basic (VB) Editor. Follow the steps outlined here to
create a new user form and populate it with the necessary controls:

1 Right-click on the VBAProject item in the project window and select
Insert>UserForm from the pop-up menu.
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2 A new form appears under Forms in the VBA Project. In the form’s property
page, set the Name property to frmFourier and the Caption property to
Spectral Analysis.

icrosoft ¥isual Basic - Fourier.xls - [Fourier.xls - frmFourier (UserForm)]

—1oix]
—lalx|

Controls |

~Input Data:
Input Data:

Sampling Interval:

Sheet3 (Sheet3)
I Plo time domain signal and power spectral density

A& Thistiorkbook
{3 Farms

: FrmFourier - Qukput Data-
[=1-£53 Modules Frequency:
82 FourierMsin [ o

FFT - Real Part:

Properties - frmFour

[frmFourier UserForm

[
I

Aphabetic | categoried | FFT - Imaginary Part:
frmFourier - J

BackColor [ aHs000000FE.
lBordercolor [ aHs000001 28 Power Spectral Density:
Borderstyle 0- FrBorderstyleMone | J
(caption Spectral Analysis
lcycle 0- fmCydealForms
DravBuffer 32000 Cancel [
Enabled True
Font Tehoma
ForeColor M aHe00000128,
Height 318.75
HelpCariextD 0
espocralbashtl 3. frslosets
Lefe 0
Mouselcon (hone) [<Recdi>

v a- Default Expression [vaive [Type -
Picture (Mone) |
PictursAlignment 2 - frrPickureAlignmentCenter
PicturssizeMade - froPictureSizeModeCip
Pictur=Tiing False:
RightToL sft False:
ScrallBars 0- fscrolBarshions
ScrallHeintt 0
ScrallLeft 0
scraliTop 0

Ll

Creating the Visual Basic Form

3 Now add a series of controls to the blank form to complete the dialog, as
summarized in the following table.
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Controls Needed for Spectral Analysis Example

Control Type Control Name | Properties Purpose
CheckBox chkPlot Caption = Plots input
Plot time data and power
domain Signal [ spectral density.
and Power
Spectral
Density
CommandButton | btnOK Caption = 0K Executes the
Default = True | Lonction and
dismisses the
dialog
CommandButton | btnCancel Caption = Dismisses the
Cancel dialog without
Cancel = True execuj:mg e
function.
Frame Frame1 Caption = Input | Groups all input
Data controls.
Frame Frame2 Caption = Groups all
Output Data output controls.
Label Labeld Caption = Input | Labels the
Data: RefEdit for
input data.
Label Label?2 Caption = Labels the
Sampling TextBox for
Interval sampling
interval.
Label Label3 Caption = Labels the
Frequency: RefEdit for
frequency
output.
Label Label4 Caption = FFT - | Labels the
Real Part: RefEdit for real
part of FFT.
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Controls Needed for Spectral Analysis Example (Continued)

Control Type Control Name | Properties Purpose
Label Label5 Caption = FFT Labels the
- Imaginary RefEdit for
Part: imaginary part
of FFT.
Label Label6 Caption Labels the
= Power RefEdit for
Spectral power spectral
Density density.
RefEdit refedtInput Selects range for
input data.
RefEdit refedtFreq Selects output
range for
frequency
points.
RefEdit refedtReal Selects output

range for real
part of FFT of
input data.

RefEdit refedtImag Selects output
range for
imaginary part
of FFT of input
data.

RefEdit refedtPowSpect Selects output
range for power
spectral density
of input data.

The following figure shows the controls layout on the form.
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£

Spectral Analysis

— Inpuk Data
Input Daka:

| -l

Sampling Inkerwal:

™ Plot time domain signal and power spectral density

— Cukpuk Data
Frequency:

FFT - Real Part:

FFT - Imaginaty Patk:

Power Speckral Density:

| N

|

|

|

(0] 4 Cancel

Layout of Controls on Main Form

When the form and controls are complete, right-click on the form and select
View Code from the pop-up menu.

The following code listing shows the code to implement. Note that this code
references the control and variable names listed in Controls Needed for
Spectral Analysis Example on page 4-23. If you have given different names
for any of the controls or any global variable, change this code to reflect those
differences.

'frmFourier Event handlers
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Private Sub UserForm_Activate()
'UserForm Activate event handler. This function gets called before
'showing the form, and initializes all controls with values stored
'in global variables.
On Error GoTo Handle_Error
If theFourier Is Nothing Or theFFTData Is Nothing Then Exit Sub
'Initialize controls with current state
If Not InputData Is Nothing Then
refedtInput.Text = InputData.Address
End If
edtSample.Text = Format(Interval)
If Not Frequency Is Nothing Then
refedtFreq.Text = Frequency.Address
End If
If Not IsEmpty (theFFTData.Real) Then
If IsObject(theFFTData.Real) And TypeOf theFFTData.Real Is Range Then
refedtReal.Text = theFFTData.Real.Address
End If
End If
If Not IsEmpty (theFFTData.Imag) Then
If IsObject(theFFTData.Imag) And TypeOf theFFTData.Imag Is Range Then
refedtImag.Text = theFFTData.Imag.Address
End If
End If
If Not PowerSpect Is Nothing Then
refedtPowSpect.Text = PowerSpect.Address
End If
chkPlot.Value = bPlot
Exit Sub
Handle_Error:
MsgBox (Err.Description)
End Sub

Private Sub btnCancel_Click()
‘Cancel button click event handler. Exits form without computing fft
'or updating variables.
Unload Me
End Sub
Private Sub btnOK_Click()
'OK button click event handler. Updates state of all variables from controls
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'and executes the computefft or plotfft method.
Dim R As Range

If theFourier Is Nothing Or theFFTData Is Nothing Then GoTo Exit_Form
On Error Resume Next
'Process inputs
Set R = Range(refedtInput.Text)
If Err <> 0 Then
MsgBox ("Invalid range entered for Input Data")
Exit Sub
End If
Set InputData = R
Interval = CDbl(edtSample.Text)
If Err <> 0 Or Interval <= 0 Then
MsgBox ("Sampling interval must be greater than zero")
Exit Sub
End If
'Process Outputs
Set R = Range(refedtFreq.Text)
If Err = 0 Then
Set Frequency = R
End If
Set R = Range(refedtReal.Text)
If Err = 0 Then
theFFTData.Real = R
End If
Set R = Range(refedtImag.Text)
If Err = 0 Then
theFFTData.Imag = R
End If
Set R = Range(refedtPowSpect.Text)
If Err = 0 Then
Set PowerSpect = R
End If
bPlot = chkPlot.Value
'Compute the fft and optionally plot power spectral density
If bPlot Then
Call theFourier.plotfft(3, theFFTData, Frequency, PowerSpect,
InputbData, Interval)
Else
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Call theFourier.computefft(3, theFFTData, Frequency, PowerSpect,
InputData, Interval)
End If
GoTo Exit_Form
Handle_Error:
MsgBox (Err.Description)
Exit_Form:
Unload Me
End Sub

Adding The Spectral Analysis Menu Item to Excel

The last step in the integration process adds a menu item to Excel so that
you can invoke the tool from Excel’s Tools menu. To do this you add event
handlers for the workbook’s AddinInstall and AddinUninstall events that
install and uninstall menu items. The menu item calls the LoadFourier
function in the FourierMain module. Follow these steps to implement the
menu item:

1 Right-click on the ThisWorkbook item in the VBA project window and
select View Code from the pop-up menu.
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. workbaok (Code)] =181x|
| Eie Edit Yew Insert Format Debug Run Iools Add-Ins Window Help =] 5[‘
|E@- e oo ) 0 wbd | 82| @] w0 5

Project - ¥BAProject [orkbook =] [nadininstan |
= =
Private Sub Workbook AddinInstall() =

VBAProject (Book1) 'Called vhen Addin is installed I~

&4 VBAProject (Fourier.xls) Call AddFourierMenultem
osoft Excel Objects End Sub

e
: Shest (Sheet1) Private Sub Vorkbook AddinUninstall()
SheetZ {Sheetz) 'Called when Addin is uninstalled

h Sheet3 (Sheet3) Call RemoveFourierMenultem
¢ 8] Thisworkbook End Sub
(=123 Forms Private Sub AddFourierMenultemi)
i [ FrmFourier Dim ToolsMenu As ComuandBarPopup
(=123 Modules Dim NewMenultem Ls ComwandBarButton

“-+82 FourierMain
'Remove if already exists

[Properties - ThisWorkboo X call RemoveFourierMenuTtew
[Thisworkbook Workbook = | 'Tind Tools wenu
Set ToolsMenu = Application.CommendBers (i) .FindControl{ID:=30007)

Alphabetic Icatew'ze“l If ToolsMenu Is Nothing Then Exit Sub

Thisworkbook '2dd Spectral Analysis wenu item
AcceptLabelsinFormulas  False Set NewMenuItem = ToolsMenu.Controls.ldd(Type:=msoControlButton)
AutolpdeteFrequency 0 Newlenultem.Caption = "Spectral inalysis..."
ChangeHistoryDuration 0 NewlenuItem.onketion = "LoadFourier"
(ConfiictResolution 1 - wllserResolution End Sub
Date1904 False Private Sub RemoveFourierMenultem() |
DisplayDrawingObjects  -4104 - xDisplayShapes Dim CmdBar is ComandBar
Envelopetisible False Dim Ctrl As CommandBarcontrol
HasRoutingslip False On Error Resume Next
HighlightChangesonScreen False 'Find tools menu end remove Spectral inalysis menu item
1saddin False _I;I
KeepChangeHistory True JKN | L4
ListChangesOrilewshest  False ocals =
PersonalviewListSettings  True
PersonallfiewPrintSettings  True |<Reedv> _I
PrecisionasDisplayed False e Tvae Trype =
saved True
saveLinkalues True
[showConflictHistory False
TemplateRemoveExtData  False
UpdateRemateReferences True

Adding a Menu Item to Excel
2 Place the code below into ThisWorkbook.

Private Sub Workbook_ AddinInstall()

‘Called when Addin is installed
Call AddFourierMenuItem

End Sub

Private Sub Workbook_AddinUninstall()

‘Called when Addin is uninstalled
Call RemoveFourierMenuItem

End Sub

Private Sub AddFourierMenuItem()

Dim ToolsMenu As CommandBarPopup
Dim NewMenuItem As CommandBarButton
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'Remove if already exists

Call RemoveFourierMenuItem

'Find Tools menu

Set ToolsMenu = Application.CommandBars(1).FindControl(ID:=30007)
If ToolsMenu Is Nothing Then Exit Sub

'Add Spectral Analysis menu item

Set NewMenuItem = ToolsMenu.Controls.Add(Type:=msoControlButton)

NewMenuItem.Caption = "Spectral Analysis..."
NewMenuItem.OnAction = "LoadFourier"
End Sub

Private Sub RemoveFourierMenuItem()

Dim CmdBar As CommandBar

Dim Ctrl As CommandBarControl

On Error Resume Next

'Find tools menu and remove Spectral Analysis menu item
Set CmdBar = Application.CommandBars(1)

Set Ctrl = CmdBar.FindControl(ID:=30007)

Call Ctrl.Controls("Spectral Analysis...").Delete

End Sub

Saving the Add-In

Now that the VBA coding is complete, you can save the add-in. Save this
file into the <project-directory>\distrib directory that mx1tool created
when building the project. Here, <project-directory> refers to the project
directory that mx1tool used to save the Fourier project. Name the add-in
Spectral Analysis.

Follow these steps to save the add-in:

1 From the main menu in Excel, select File>Properties.

2 When the Workbook Properties dialog appears, select the Summary tab
and enter Spectral Analysis as the workbook title.

3 Click OK to save the edits.

4 Select File>Save As from the Excel main menu.
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5 When the Save As dialog appears, select Microsoft Excel Add-In (*.xla)
as the file type, and browse to <project-directory>\distrib.

6 Enter Fourier.xla as the filename and click Save to save the add-in.

Testing The Add-In

Before distributing the add-in, test it with a sample problem. Spectral
analysis is commonly used to find the frequency components of a signal
buried in a noisy time domain signal. In this example you will create a data
representation of a signal containing two distinct components and add to it a
random component. This data along with the output will be stored in columns
of an Excel worksheet, and you will plot the time-domain signal along with
the power spectral density.

Follow the steps outlined below to create the test problem:

1 Start a new session of Excel with a blank workbook.
2 Select Tools>Add-Ins from the main menu.
3 When the Add-Ins dialog comes up, click Browse.

4 Browse to the <project-directory>\distrib directory, select
Fourier.xla and click OK.

5 The Spectral Analysis add-in appears in the available Add-Ins list and
is selected.

6 Click OK to load the add-in.

This add-in installs a menu item under the Excel Tools menu. You can display
the Spectral Analysis GUI by selecting Tools>Spectral Analysis. Before
invoking the add-in, create some data, in this case a signal with components
at 15 and 40 Hz. Sample the signal for 10 seconds at a sampling rate of 0.01 s.
Put the time points into column A and the signal points into column B.

Creating the Data
Follow these steps to create the data:

1 Enter 0 for cell Al in the current worksheet.
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Click on cell A2 and type the formula "= A1 + 0.01".

Click and hold on the lower right hand corner of cell A2 and drag the
formula down the column to cell A1001. This procedure fills the range
A1:A1001 with the interval 0 to 10 incremented by 0.01.

Click on cell B1 and type the formula "= SIN(2*PI()*15*A1) +
SIN(2*PI()*40*A1) + RAND()". Repeat the drag procedure to copy this
formula to all cells in the range B1:B1001.

Running the Test
Using the column of data (column B), test the add-in as follows:

2

7

Select Tools>Spectral Analysis from the main menu.
Click on the Input Data box.

Select the B1:B1001 range from the worksheet or type this address into
Input Data.

Click on the Sampling Interval box and type 0.01.
Select Plot time domain signal and power spectral density.

Enter C1:C1001 for frequency output, and likewise enter D1:D1001,
E1:E1001, and F1:F1001 for the FFT real and imaginary parts, and
spectral density.

Click OK to run the analysis.

The next figure shows the output.
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The power spectral density reveals the two signals at 15 and 40 Hz.

Package the Add-In

As a final step, package the add-in, the COM component, and all supporting
libraries into a self-extracting executable. This package can now be installed
onto other computers that need to use the Spectral Analysis add-in.

To package the add-in, follow these steps.

1 Return to mx1tool. If mx1tool has been dismissed, start it again and
reload the Fourier project.

2 Select Component>Package Component.
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This command creates the Fourier.exe self-extracting executable. To install
this add-in onto another computer, copy the Fourier.exe package to that
machine, run it from a command prompt, and follow the instructions.
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Introduction (p. 5-2)

Installing the Function Wizard
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Function Wizard.

Procedure for installing the Add-In

How to open the Function Viewer

How to load and execute functions

How to view components currently
installed

How to edit inputs and outputs to
functions

How to select worksheet ranges and
specify values

How to rename, copy, and move
functions
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Introduction

The Function Wizard enables you to pass Microsoft Excel (Excel 2000 or later)
worksheet values to a compiled MATLAB model and to return model output
to a cell or range of cells in the worksheet. The Function Wizard provides

an intuitive interface to Excel worksheets. Knowledge of Visual Basic for
Applications (VBA) programming is not required.

The Function Wizard reflects any changes that you make in the worksheets,
such as range selections. Going in the opposite direction, you can use the
Function Wizard to control the placement and output of data from MATLAB
functions to the worksheets.

The Function Wizard does not currently support the MATLAB struct,
sparse, and complex data types.
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Installing the Function Wizard Add-In

The Function Wizard GUI is contained in an Excel add-in (m1function.xla)
residing in the <matlab>\toolbox\matlabxl\matlabxl directory. You must
install this add-in before using the Function Wizard.

Follow these steps to install the add-in:

1 Select Tools>Add-Ins from the Excel main menu.

2 Ifthe Function Wizard was previously installed, a reference to MATLAB
Function Wizard appears in the list. Select the item and click OK.

If the Function Wizard was not previously installed, click Browse and
proceed to the <matlab>\toolbox\matlabx1l\matlabxl directory. Select
mlfunction.xla. Click OK on this dialog box and on the preceding one.

The Function Wizard is also packaged with all deployed components. When
a component is installed onto a separate machine, the Function Wizard is
placed into the top-level directory of the installed component. In this case see
the instructions above, substituting the installed component’s directory.
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Starting the Function Wizard

To start the Function Wizard, click on Tools > MATLAB Functions on

the Excel menu bar. The starting point of the Function Wizard, called the
Function Viewer, now displays.

MATLAE Functions

x|
— Worksheet Functions
Ackive | Function |
myprimes
Cholesky
Mew, .. Edit... Copy... Move Up
Delete Rename. .. shift Cells... Move Down
Execute Done Help
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Understanding the Function Viewer

The Function Viewer controls the execution of worksheet functions. Use the
Function Viewer to organize the list of all currently loaded Excel Builder
functions.

Using the Function Viewer

The Function Viewer displays the names of all loaded functions. You can edit
this name to provide a more descriptive identifier. A check box for each entry
denotes the active/inactive state of each function. Inactive functions are not
executed when you click the Execute button.

Below the function list is a panel of eight buttons. To add a new component to
the list of loaded worksheet functions, click the New button. (See “Component
Browser” on page 5-7).

Each of the other buttons performs a specific action on the currently selected
function. To select a function, left-click the list item. The row becomes
highlighted. You can change the current selection by left-clicking on a
different list item or by using the up and down arrow keys on your keyboard.

Loading and Executing Functions

To load and execute an Excel Builder function in your worksheet requires
three steps:

1 Load an Excel Builder component.

Click the New button on the Function Viewer to display the
Component Browser. (See “Component Browser” on page 5-7.) Use
this browser to select the component you want to load from the list of
all currently installed Excel Builder components. From the selected
component, add the method that you want to call.

2 Set the inputs, outputs, and other properties of your function.

Click the Edit button to display the Function Properties dialog box. (See
“Function Properties” on page 5-8.)
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3 Click the Execute button on the Function Viewer.

When you click the Execute button, functions execute in the order
displayed in the list.
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Component Browser

The Component Browser lists all Excel Builder components currently

installed on the system. When you click the New button on the Function
Viewer, this dialog box displays.

MATLAB Components

— Awailable Components
ﬂ MATLAB Excel Builder Components
-k randamwalk 1,0

E| mycomponent 1.0

— Current Selections

| v

Function Mame |
myprimes

- function [v] = sumtoln)

mymatrix 1.0

% mmatriz 2,0 | _ILI
»

. BB mydass
i function [x] = getdatesin, inc)
function [p] = myprimes{n) Add > |
function [v] = mysumivararging

Funckion [y, varargout] = mysum2(x, varz <- Remave |
function [varargout] = randvectors

A

4

0K I Cancel | Help

The Component Browser lists each component by name and version.
Expanding a component reveals the class name at the next level. You can also

expand the class to reveal the MATLAB functions that make up the class
methods.

Select the desired method and click the Add button to add a function. To
load all methods of a class, select the class name and click Add. Added
functions appear under Current Selections on right of the browser. To
remove a function before returning to the Function Viewer, highlight it under
Current Selections and click the Remove button.
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This group of dialog boxes sets properties and values for the inputs and
outputs. You can map inputs and outputs to ranges in your worksheet. You
can also rename a function with any of these dialog boxes.

When you click the Edit button on the Function Viewer, the Function
Properties dialog box appears, as shown:

Function Properties |

x|

— Edit Function properties
Function syntax:

function [, warargout] = mysum2(x, varargin)

Edit function name:

I ysUmne

Inputs. | gutputs |

— Select Input Ranges/values
* Reguired Arguments [ warargin Argurments

Input Argurments

Argument | Range/ialue
X $AL1:$A%10
Add Delete | Propetties., .. |

Done Help
b |

The Add and Delete buttons become active when you select

varargin Arguments.

Select the Outputs tab to switch to editing outputs.

Editing Function Arguments
Function arguments may be either required arguments or

varargin/varargout arguments:
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® Required arguments appear first on the left or right sides of a MATLAB
function and are not named varargin or varargout.

® varargin/varargout arguments always appear as the last input or
output. They allow you to specify a variable number of arguments.

Editing Required Arguments
To edit required arguments, select the argument in the list and click the
Properties button.

Before you can edit varargin/varargout arguments, you must first explicitly
add them using the Add button. If the MATLAB function does not have
varargin/varargout arguments, the ability to add arguments to the list is
disabled. Once you have added varargin/varargout arguments, you can
edit them in the same way as required arguments. When you are editing
varargin/varargout arguments, the Function Properties dialog box appears
as shown:

Function Properties | x|

— Edit Function properties
Function syntax:

function [, warargout] = mysum2(x, varargin)

Edit function name:

ysUmne

Inputs Qutputs

— Select Qutput Ranges

(o Reguired Arguments o warargouk Argurments
warargouk
Argument | Range/ialue |

warargout[1] $B412
varargout[2] $CH12

Add Delete | Propetties., .. |
v |
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Editing Required Outputs
When you are editing required output arguments, the Function Properties
dialog box appears as shown:

Function Properties | ll

— Edit Function properties
Function syntax:

function [, warargout] = mysum2(x, varargin)

Edit function name:

ysUmne

Inputs Qutputs

— Select Qutput Ranges
* Reguired Arguments [ warargouk Argurments

Cutput Argurnents

Argument | Range/ialue |
¥ $A%12

Add Delete | Propetties., .. |
v |

The Add and Delete buttons become active when you select
varargout Arguments.

Select the Inputs tab to switch to editing inputs.

Editing varargout Outputs

When you are editing varargout outputs, the Function Properties dialog
box appears as shown:

5-10



Function Properties

— Edit Function properties
Function syntax:

function [, warargout] = mysum2(x, varargin)

Edit function name:

I ysUmne

Inputs. | gutputs |

— Select Input Ranges/values

(o Reguired Arguments o warargin Argurments
warargin
Argument | Range/ialue |

warargin[1] $B41:46410
varargin[2] $CH1:$C410

Add Delete | Propetties., .. |
v |
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Argument Properties

The Argument Properties and related dialog boxes allow you to select
worksheet ranges or optionally enter a specific value for an input argument.
These dialog boxes are as follows:

® “Input Argument Properties Dialog Box” on page 5-12
® “Output Argument Properties Dialog Box” on page 5-13

Input Argument Properties Dialog Box

Here is an example of the Argument Properties dialog box for input
arguments. In this example, the input arguments have a range of A1 to A10.

Argument Properties for x x|

— Set Rangejvalue for Input Argument

' Range:

1

™ Auto recalculate on changs
Type:
Double =
" Walue: I J

Options. ..

|

Input Argument Properties Dialog Box

From this dialog box you can:
® Select the Range dropdown list to specify a range of current input
arguments.

® Select Auto recalclulate on change to tell Excel Builder to recalculate
the current function when any cell in the current arugment changes.

® Select the Value dropdown list to set a single value for the current
argument. Then select the type from the Type dropdown list.

¢ (Click Options to set the conversion options. Then set the options in the
Input Conversion Options dialog appears as shown:
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Input Conversion Options E[

— Set Conversion Options far x
Farmat Array As: Coerce Mumeric ba Type:

i el Diefaulk j

Format Dakes As:

' Mumeric 8 Skring

Ik | Zancel

Input Conversion Options Dialog Box

Output Argument Properties Dialog Box

Here is an example of the Argument Properties dialog box for output
arguments. In this example, the output argument is A12.

Argument Properties for ¥ i ll

Set RangeValue For Output Argument

o

|7 Auto Resize |_ Transpose |_ Output As date

o |

Output Argument Properties Dialog Box

From this dialog box you can:

* From the Range dropdown list, select the worksheet range to be used as
the output argument.

® Select Auto resize to tell Excel Builder to adjust the output range to fit
the output array. This setting is useful when the target output from a
method call is a range of cells in an Excel worksheet and the output array
size and shape is not known at the time of the call.

® Select Transpose output to transpose the output arguments. This setting
is useful when calling a component where the MATLAB function returns
outputs as row vectors, and you want the data in columns.

® Select Output as date to coerce the output values to become Excel dates.
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Function Utilities
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Excel Builder supports several function utilities, which you use via the
following dialog boxes:

¢ “Rename Function Dialog Box” on page 5-14

® “Copy Function Dialog Box” on page 5-14

e “Move Function Dialog Box” on page 5-15

Rename Function Dialog Box

Use the Rename Function dialog box to rename a function. To open this dialog
box, click Rename on the Function Viewer. Here is an example of this dialog
box, with mysum2 as the new function name.

Set Function Mame
’7 TiysUmE
concel_|

In this dialog box, you can

e Enter a new name for the selected function.
e (Click OK to save the new name and return to the Function Viewer.

¢ (Click Cancel to return to the Function Viewer without saving the new
name.

Copy Function Dialog Box

Use the Copy Function dialog box to make copies of the current function. To
open this dialog box, click Copy on the Function Viewer.

The Copy Function dialog box has two tabs.
* The Standard Copy tab creates a specified number of copies of the

function while copying any argument/range values you have set. Here is an
illustration of this dialog box, with the number of copies, set to 1:
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Copy Function

Standard I Advanced |

Create copies of function

Mumber of Copies: I 1 ﬂ

Cancel | Help |

¢ The Advanced tab creates a rectangular array of copies of the current
function in the current worksheet, and optionally copies the cell contents of
ranges referenced by the function’s arguments.

When you set the number of rows and columns and the row/column
increments, the copy process automatically updates cell references by the
specified increment amounts.

= Positive increments move rows down and columns to the right.
= Negative increments move rows up and columns to the left.

The following example shows the Advanced tab:

Copy Function

Standard  Advanced I

Create an array of copies and update cell references

MNumber of Rows:l 2 ﬂ Mumber of Colurns: I 2 ﬂ
= 3 =
Row increment: + | Column increment: =

IV Copy cell contents

Total number of copies including original: ¢

0K I Cancell Help |

Move Function Dialog Box

Use the Move Function dialog box to move the currently selected function to a
new position in the current worksheet.

When you set the row and column increments, the move process automatically
updates cell references by these values.
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® Positive increments move rows down and columns to the right.
® Negative increments move rows up and columns to the left.

You can also optionally move the cell contents of any ranges referenced by
the function.

Here is an illustration of the Move Function dialog box, set to move the
location by two rows and two columns, and to move the cell contents:

x

Move the location of the current function

2 = 2 =
Row increment: + | Column increment: &

¥ Mowe cell contents

[o]'4 I Cancell Helo |
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componentinfo

Purpose Query system registry for details about a component created with
MATLAB Builder for Excel

Syntax componentinfo
componentinfo (component_name)
componentinfo (component_name, major_revision_number)
componentinfo (component_name, major_revision_number,
minor_revision_number)

Arguments
component_name MATLAB string providing the name
of a MATLAB Builder for Excel
component. Names are case sensitive.
If this argument is not supplied, the
function returns information on all
installed components.

major_revision_number Component major revision number.
If this argument is not supplied, the
function returns information on all
major revisions.

minor_revision_number Component minor revision number.
Default value is 0.

Descri ption componentinfo returns information for all components installed on
the system.

componentinfo (component_name) returns information for all revisions
of component_name.

componentinfo (component_name, major_revision_number) returns
information for the most recent minor revision corresponding to
major_revision_number of component name..

componentinfo (component_name, major_revision_number,
minor_revision number) returns information for the specific major and
minor version of component_name.
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The return value is an array of structures representing all the registry
and type information needed to load and use the component.

When you supply a component name, major_revision number and
minor_revision_number are interpreted as shown below.

Value | Information Returned

>0 Information on a specific major and minor revision

0 Information on the most recent revision
When omitted, minor revision number is assumed to be
equal to 0.

<0 Information on all versions

Note Although properties and events may appear in the output for
componentinfo, they are not supported by Excel Builder components.

Registry The information about a component has the fields shown in the
Information following table.

Registry Information Returned by componentinfo

Field Description

Name Component name

TypelLib Component type library

LIBID Component type library GUID
MajorRev Major version number
MinorRev Minor version number
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Field

Description

FileName

Type library filename and

path. Since all Excel Builder
components have the type library
bound into the DLL, this filename
is the same as the DLL name and
path.

Interfaces

An array of structures defining all
interface definitions in the type
library. Each structure contains
two fields:

e Name— Interface name

e IID-Interface GUID

CoClasses

An array of structures defining all
COM classes in the component.
Each structure contains these
fields:

e Name—Class name
e CLSID —GUID of the class

® ProgID —Version dependent
program ID

e VerIndProgID —Version
independent program ID

® InprocServer32—-Full name
and path to component DLL

® Methods—A structure
containing function prototypes
of all class methods defined for
this interface. This structure
contains four fields:
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Field

Description

= IDL-An array of Interface
Description Language
function prototypes

= M-An array of MATLAB
function prototypes

= C-An array of C-language
function prototypes

= VB-An array of VBA function
prototypes

e Properties—A cell array
containing the names of
all class properties.

e Events—A structure
containing function
prototypes of all events
defined for this class.
This structure contains
four fields:

e IDL—An array of IDL
(Interface Description
Language) function
prototypes.

e M—An array of MATLAB
function prototypes.

e C—An array of
C-Language function
prototypes.

e VB-An array of VBA
function prototypes
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Examples
Function Call Returns
Info = componentinfo Information for all installed

components.

Info = Information for all revisions
componentinfo('mycomponent’) of mycomponent.
Info = Information for revision 1.0
componentinfo('mycomponent',1,0) of mycomponent.

See Also “Obtaining Registry Information” on page A-6
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Pu rpose Open graphical user interface to MATLAB Builder for Excel
Syntax mx1ltool
Description The mx1tool command displays the MATLAB Builder window, which is

the graphical user interface (GUI) for MATLAB Builder for Excel.

«): MATLAB Builder

File Project Build Component Help
rProject File Build Statu
A Eile |
# ProjectFiles
Edit | BErmaye | E{ear
See Also “Building a Deployable Application” on page 1-2

Chapter 3, “Programming with MATLAB Builder for Excel”
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Overview of Internal Processes

MATLAB Builder for Excel enables you to pass Microsoft Excel worksheet
values to a compiled MATLAB model via VBA and to return model output

to a cell or range of cells in the worksheet. Each Excel Builder component

is built as a stand-alone COM object. Each MATLAB function included in

a given component appears as a method of the created COM class. The
resulting call syntax from VB is systematicallymapped to the syntax of the
original MATLAB. This mapping provides a bridge from MATLAB, where the
functions are created, to VB, where the functions are ultimately called. The
following conceptual diagram illustrates the process:

M-files mycomponent_1_0.dll

Unknown

foo.m

bar.m MATLAB Imyciass
Compiler

IDispatch

1SupportErrorinfo
User supplied information:

Class name: myclass
Component name: mycomponent
Version number: 1.0

The process of creating an Excel Builder component is completely automatic
from a user point of view. You specify a list of M-files to process and a few
additional pieces of information, such as the component name, the class
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names, and the version number. The build process involves the following
steps:

1 “Code Generation” on page A-4

2 “Create Interface Definitions” on page A-5

3 “C++ Compilation” on page A-5

4 “Linking and Resource Binding” on page A-5
5 “Component Registration” on page A-5

These steps are shown in the following diagram and explained in the
subsequent sections.
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The first step in the build process generates all source code and other
supporting files needed to create the component. It also creates the main
source file (nycomponent_dll.cpp) containing the implementation of each
exported function of the DLL. The compiler additionally produces an Interface
Description Language (IDL) file (nycomponent_idl.idl), containing the
specifications for the component’s type library, interface, and class, with
associated GUIDs. (GUID is an acronym for Globally Unique Identifier, a
128-bit integer guaranteed always to be unique.)
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Created next are the C++ class definition and implementation files
(myclass_com.hpp and myclass_com.cpp). In addition to these source
files, the compiler generates a DLL exports file (nycomponent.def), a
resource script (mycomponent.rc), and a Component Technology File
(mycomponent.ctf). See the MATLAB Compiler documentation for a
discussion of ctf files.

Create Interface Definitions

The second step of the build process invokes the IDL compiler on the IDL file
generated in step 1 (mycomponent _idl.idl), creating the interface header
file (mycomponent_idl.h), the interface GUID file (mycomponent idl i.c),
and the component type library file (nycomponent_idl.t1lb). The interface
header file contains type definitions and function declarations based on the
interface definition in the IDL file. The interface GUID file contains the
definitions of the GUIDs from all interfaces in the IDL file. The component
type library file contains a binary representation of all types and objects
exposed by the component.

C++ Compilation

The third step compiles all C/C++ source files generated in steps 1 and

2 into object code. One additional file containing a set of C++ template
classes (mclcomclass.h) is included at this point. This file contains template
implementations of all necessary COM base classes, as well as error handling
and registration code.

Linking and Resource Binding

The fourth step produces the finished DLL for the component. This step
invokes the linker on the object files generated in step 3 and the necessary
MATLAB libraries to produce a DLL component (mycomponent 1 _0.d11l). The
resource compiler is then invoked on the DLL, along with the resource script
generated in step 1, to bind the type library file generated in step 2 into the
completed DLL.

Component Registration

The final build step registers the DLL on the system, as described in the
next section.
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Component Registration

When Excel Builder creates a component, it automatically generates a binary
file called a type library. As a final step of the build, this file is bound with the
resulting DLL as a resource.

When programming with Excel components you might need details about
a component. You can use componentinfo, which is a MATLAB function,
to query the system registry for details about any installed Excel Builder
component.

Obtaining Registry Information

When programming with COM components you might need details about
a component. You can use componentinfo, which is a MATLAB function,
to query the system registry for details about any installed Excel Builder
component.

Query the Register for Information about a Component
This example queries the registry for a component named mycomponent and

a version of 1.0. This component has four methods: mysum, randvectors,
getdates, and myprimes, two properties: m and n, and one event: myevent.

Info = componentinfo('mycomponent', 1, 0)

Info

Name: 'mycomponent'’
TypeLib: 'mycomponent 1.0 Type Library'
LIBID: '{3A14AB34-44BE-11D5-B155-00D0B7BA7544}"

MajorRev: 1

MinorRev: 0O

FileName: 'D:\Work\ mycomponent\distrib\mycomponent 1 0.d11'
Interfaces: [1x1 struct]

CoClasses: [1x1 struct]

Info.Interfaces

ans =
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Name: 'Imyclass’
IID: '{3A14AB36-44BE-11D5-B155-00D0B7BA7544}"

Info.CoClasses
ans =
Name: 'myclass'
CLSID: '{3A14AB35-44BE-11D5-B155-00D0B7BA7544}"
ProgID: 'mycomponent.myclass.1_0'
VerIndProgID: 'mycomponent.myclass'
InprocServer32: 'D:\Work\mycomponent\distrib\mycomponent 1 _0.d11'
Methods: [1x4 struct]
Properties: {'m', 'n'}
Events: [1x1 struct]
Info.CoClasses.Events.M
ans =
function myevent(x, y)
Info.CoClasses.Methods
ans =
1x4 struct array with fields:
IDL
M
C
VB
Info.CoClasses.Methods.M
ans =

function [y] = mysum(varargin)

ans =
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function [varargout] = randvectors()
ans =

function [x] = getdates(n, inc)

ans =

function [p] myprimes(n)
The returned structure contains fields corresponding to the most important
information from the registry and type library for the component.

Self-Registering Components

Excel Builder components are all self registering. A self registering component
contains all the necessary code to add or remove a full description of itself to
or from the system registry. The mwregsvr utility, distributed with the MCR,
registers self-registering DLLs. For example, to register a component called
mycomponent 1 0.d1l, issue this command at the DOS command prompt.

mwregsvr mycomponent_1 0.d1l1l

When mwregsvr completes the registration process, it displays a message
indicating success or failure. Similarly, the command

mwregsvr /u mycomponent_1_0.d1l
unregisters the component.

An Excel Builder component installed onto a particular machine must be
registered with mwregsvr. If you move a component into a different directory
on the same machine, you must repeat the registration process. When
deleting a component from a specific machine, first unregister it to ensure
that the registry does not retain erroneous information.
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Note The mwregsvr utility invokes a process that is similar to regsvr32.exe,
except that mwregsvr does not require interaction with a user at the console.
The regsvr32.exe process belongs to the Windows OS and is used to register
dynamic-link libraries and ActiveX controls in the registry. This program is
important for the stable and secure running of your computer and should not
be terminated. You can use regsvr32.exe as an alternative to mwregsvr to
register your library.

Globally Unique Identifier (GUID)

Information is stored in the registry as keys with one or more associated
named values. The keys themselves have values of primarily two types:

readable strings and GUIDs. (GUID is an acronym for Globally Unique

Identifier, a 128-bit integer guaranteed always to be unique.)

Excel Builder automatically generates GUIDs for COM classes, interfaces,
and type libraries that are defined within a component at build time, and
codes these keys into the component’s self-registration code.

The interface to the system registry is directory based. COM-related
information is stored under a top-level key called HKEY CLASSES ROOT. Under
HKEY_CLASSES_ROOT are several other keys under which Excel Builder writes
component information. See the following table for a list of the keys and
their definitions.

Keys
Key Definition
HKEY_CLASSES_ROOT\CLSID Information about COM classes on the system.

Each component creates a new key under
HKEY_CLASSES_ROOT\CLSID for each of its COM
classes. The key created has a value of the GUID
that has been assigned the class and contains
several subkeys with information about the class.




A

Producing a COM Object from MATLAB

A-10

Keys (Continued)

Key

Definition

HKEY_CLASSES_ROOT\Interface

Information about COM interfaces on the system.
Each component creates a new key under
HKEY_CLASSES_ROOT\Interface for each interface
it defines. This key has the value of the GUID
assigned to the interface and contains subkeys
with information about the interface.

HKEY_CLASSES_ROOT\TypeLib

Information about type libraries on the system.
Each component creates a key for its type library
with the value of the GUID assigned to it. Under
this key a new key is created for each version

of the type library. Therefore, new versions of
type libraries with the same name reuse the
original GUID but create a new subkey for the
new version.

HKEY_CLASSES_ROOT\<ProgID>,
HKEY_CLASSES_ROOT\<VerIndProgID>

These two keys are created for the component’s
Program ID and Version Independent Program

ID. These keys are constructed from strings

of the form <component-name>.<class-name> and
<component-name>.<class-name><version-number>.
These keys are useful for creating a class instance
from the component and class names instead

of the GUIDs.

Versioning

MATLAB Builder for Excel components support a simple versioning
mechanism designed to make building and deploying multiple versions of the
same component easy to implement. The version number of a component
appears as part of the DLL name, as well as part of the version-dependent ID

in the system registry.

When a component is created, you can specify a version number (default =
1.0). During the development of a specific version of a component, the version
number should be kept constant. When this is done, the MATLAB Compiler,
in certain cases, reuses type library, class, and interface GUIDs for each



Component Registration

subsequent build of the component. This avoids the creation of an excessive
number of registry keys for the same component during multiple builds, as
occurs if new GUIDs are generated for each build.

When a new version number is introduced, the MATLAB Compiler generates
new class and interface GUIDs so that the system recognizes them as distinct
from previous versions, even if the class name is the same. Therefore, once you
deploy a built component, use a new version number for any changes made
to the component. This ensures that after you deploy the new component, it
is easy to manage the two versions.

The MATLAB Compiler implements the versioning rules for a specific
component name, class name, and version number by querying the system
registry for an existing component with the same name:

¢ If an existing component has the same version, it uses the GUID of the
existing component’s type library. If the name of the new class matches the
previous version, it reuses the class and interface GUIDs. If the class names
do not match, it generates new GUIDs for the new class and interface.

e Ifit finds an existing component with a different version, it uses the
existing type library GUID and creates a new subkey for the new version
number. It generates new GUIDs for the new class and interface.

e Ifit does not find an existing component of the specified name, it generates
new GUIDs for the component’s type library, class, and interface.
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Calling Conventions

This section describes the calling conventions for MATLAB Builder for Excel
components, including mappings from the original M-functions to VBA. A
function call originating from an Excel worksheet is routed from a VBA
function into a compiled M-function, as shown in the following conceptual
illustration:

Excel Application

sub

foo(yl,y2,x1,x2)

Visud Basic function /subroutine

myeloss
object§ :

COM dass.method

N\

‘ function [yl,y2] =

Compiled M-function

Producing a COM Class

Producing a COM class requires the generation of a class definition file in
Interface Description Language (IDL) as well as the associated C++ class
definition/implementation files. (See the Microsoft COM documentation for a
complete discussion of IDL and C++ coding rules for building COM objects.)
The builder automatically produces the necessary IDL and C/C++ code to
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build each COM class in the component. This process is generally transparent
to the user.

As a final step, Excel Builder produces a VBA function wrapper for each
method, used to implement an Excel formula function. Formula functions are
useful when calling a method that returns a single scalar value with one

or more inputs. Use a general VBA subroutine when calling a method that
returns array data or multiple outputs.

IDL Mapping
The most generic MATLAB M-function is

function [Y1, Y2, ..., varargout] = foo(X1, X2, ..., varargin)
This function maps directly to the following IDL signature.

HRESULT foo([in] long nargout,
[in,out] VARIANT* Y1,
[in,out] VARIANT* Y2,

[in,out] VARIANT* varargout,
[in] VARIANT X1,
[in] VARIANT X2,

[in] VARIANT varargin);

This IDL function definition is generated by producing a function with the
same name as the original M-function and an argument list containing all
inputs and outputs of the original plus one additional parameter, nargout.
(nargout is not produced if you compile an M-function containing no outputs.)
When present, the nargout parameter is an [in] parameter of type long.

It is always the first argument in the list. This parameter allows correct
passage of the MATLAB nargout parameter to the compiled M-code.
Following the nargout parameter, the outputs are listed in the order they
appear on the left side of the MATLAB function, and are tagged as [in,out],
meaning that they are passed in both directions. The function inputs are
listed next, appearing in the same order as they do on the right side of the
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original function. All inputs are tagged as [in] parameters. When present,
the optional varargin/varargout parameters are always listed as the last
input parameters and the last output parameters. All parameters other than
nargout are passed as COM VARIANT types. “Data Conversion Rules” on
page B-2 lists the rules for conversion between MATLAB arrays and COM
VARIANTS.

Visual Basic Mapping
The Visual Basic mapping to the IDL signature shown above is

Sub foo(nargout As Long, _
Y1 As Variant, _
Y2 As Variant, _

varargout As Variant, _
X1 As Variant, _
X2 As Varaint, _

varargin As Variant)

(See the COM documentation for mappings to other languages, such as C++.)
Visual Basic provides native support for COM VARIANTs with the Variant
type, as well as implicit conversions for all Visual Basic basic types to and
from Variants. In general, arrays/scalars of any Visual Basic basic type, as
well as arrays/scalars of Variant types, can be passed as arguments. Excel
Builder components also provide direct support for the Excel Range object,
used by VBA to represent a range of cells in an Excel worksheet. See the VBA
documentation included with Microsoft Excel for more information on VBA
data types and Excel Range manipulation.

MATLAB Compiler Output

Excel Builder generates a default Visual Basic function wrapper for each class
method with the following format:

Function foo(Optional X1 As Variant, _
Optional X2 As Variant, _
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Optional varargini As Variant, _
Optional varargin2 As Variant, _

Optional vararginN As Variant) _
As Variant
Dim Y1, Y2, ..., varargout As Variant
Dim varargin As Variant

(other declarations)
(function body)
foo = Y1

(error handling code)
End Function

By default, the generated formula function contains an argument list with all
the inputs to the method call and a return value corresponding to the first
output parameter. The argument list includes each explicit input parameter.
If the optional varargin parameter is present in the original MATLAB
function, additional arguments varargini, varargin2,...,vararginn are
generated, where n is a number chosen by the builder. The number n is chosen
so that the total number of inputs is less than or equal to 32. This function
generally includes a declaration for each output parameter as type Variant. If
the original MATLAB function contains a varargin, a variable is declared of
type Variant to pass collectively the varargini,...,vararginn parameters
in the form of a Variant array. The main function body contains code for

® Packing varargin parameters if available
® Creating the necessary class instance

¢ (Calling the target method
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¢ Error handling
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Data Conversion Rules (p. B-2) Converting between MATLAB and
COM variants.
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Data Conversion Rules

This section describes the data conversion rules for MATLAB Builder for
Excel components. These components are dual interface COM objects that
support data types compatible with Automation.

Note Automation (formerly called OLE Automation) is a technology that
allows software packages to expose their unique features to scripting tools
and other applications. Automation uses the Component Object Model (COM),
but may be implemented independently from other OLE features, such as
in-place activation.

When a method is invoked on an Excel Builder component, the input
parameters are converted to MATLAB internal array format and passed to the
compiled MATLAB function. When the function exits, the output parameters
are converted from MATLAB internal array format to COM Automation types.

The COM client passes all input and output arguments in the compiled
MATLAB functions as type VARIANT. The COM VARIANT type is a union of
several simple data types. A type VARIANT variable can store a variable of any
of the simple types, as well as arrays of any of these values.

The Win32 Application Program Interface (API) provides many functions for
creating and manipulating VARIANTs in C/C++, and Visual Basic provides
native language support for this type.

Note This discussion of data refers to both VARIANT and Variant data types.
VARIANT is the C++ name and Variant is the corresponding data type in
Visual Basic.

See the Visual Studio documentation for definitions and API support for COM
VARIANTs. VARIANT variables are self describing and store their type code
as an internal field of the structure.

lists the VARIANT type codes supported by Excel Builder components. and list
the data conversion rules between COM VARIANTs and MATLAB arrays.
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VARIANT Type Codes Supported

Variant Visual

VARIANT Type Code Type Code Basic

(C/C++) C/C++ Type (Visual Basic) | Type Definition

VT_EMPTY - vbEmpty - Uninitialized
VARIANT

VT I1 char - - Signed one-byte
character

VT_UI1 unsigned char | vbByte Byte Unsigned one-byte
character

VT 12 short vbInteger Integer Signed two-byte
integer

VT UI2 unsigned - - Unsigned two-byte

short integer

VT 14 long vbLong Long Signed four-byte
integer

VT UI4 unsigned long | - - Unsigned four-byte
integer

VT_R4 float vbSingle Single IEEE four-byte
floating-point value

VT _R8 double vbDouble Double IEEE eight-byte
floating-point value

VT_CY cy+ vbCurrency Currency | Currency value
(64-bit integer, scaled
by 10,000)

VT _BSTR BSTR* vbString String String value

VT_ERROR SCODE* vbError - A HRESULT (Signed

four-byte integer
representing a COM
error code)
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VARIANT Type Codes Supported (Continued)

VARIANT Type Code
(C/C++)

C/C++ Type

Variant
Type Code
(Visual Basic)

Visual
Basic

Type

Definition

VT_DATE

DATE™

vbDate

Date

Eight-byte floating
point value
representing date
and time

VT_INT

int

Signed integer;
equivalent to type
int

VT_UINT

unsigned int

Unsigned integer;
equivalent to type
unsigned int

VT_DECIMAL

DECIMAL™*

vbDecimal

96-bit (12-byte)
unsigned integer,
scaled by a variable
power of 10

VT_BOOL

VARIANT_BOOL*

vbBoolean

Boolean

Two-byte Boolean
value (OxFFFF =
True; 0x0000 = False)

VT_DISPATCH

IDispatch*

vbObject

Object

IDispatch* pointer
to an object

VT_VARIANT

VARIANT*

vbVariant

Variant

VARIANT (can only be
specified if combined
with VT_BYREF or
VT_ARRAY)

<anything>|VT_ARRAY

Bitwise combine
VT_ARRAY with any
basic type to declare
as an array
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VARIANT Type Codes Supported (Continued)

Variant Visual
VARIANT Type Code Type Code Basic
(C/C++) C/C++ Type (Visual Basic) | Type

Definition

<anything>|VT_BYREF

Bitwise combine

VT _BYREF with any
basic type to declare
as a reference to a

value
* Denotes
Windows-specific type.
Not part of standard
C/C++.
MATLAB to COM VARIANT Conversion Rules

MATLAB Data VARIANT type for VARIANT type for
Type Scalar Data Array Data Comments
cell A 1-by-1 cell array A multidimensional

converts to a single cell array converts

VARIANT with a type to a VARIANT of type

conforming to the VT_VARIANT |VT_ARRAY

conversion rule for the | with the type of
MATLAB data type of | each array member
the cell contents. conforming to the
conversion rule for the
MATLAB data type of
the corresponding cell.

structure VT_DISPATCH VT_DISPATCH

A MATLAB struct
array is converted to
an MWStruct object.
(See“Class MWStruct”
on page C-16.) This
object is passed as a
VT_DISPATCH type.
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MATLAB to COM VARIANT Conversion Rules (Continued)

MATLAB Data
Type

VARIANT type for
Scalar Data

VARIANT type for
Array Data

Comments

char

A 1-by-1 char matrix
converts to a VARIANT
of type VT_BSTR with
string length = 1.

A 1-by-L char matrix is
assumed to represent
a string of length Lin
MATLAB. This case
converts to a VARIANT
of type VT_BSTR with a
string length = L. char
matrices of more than
one row, or of a higher
dimensionality convert
to a VARIANT of type
VT_BSTR|VT_ARRAY.
Each string in the
converted array

is of length 1 and
corresponds to each
character in the
original matrix.

Arrays of strings are
not supported as char
matrices. To pass an
array of strings, use
a cell array of 1-by-L
char matrices.

sparse

VT_DISPAATCH

VT_DISPATCH

A MATLAB sparse
array is converted to
an MWSparse object.
(See “Class MWSparse”
on page C-26.) This
object is passed as a
VT_DISPATCH type.
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MATLAB to COM VARIANT Conversion Rules (Continued)

MATLAB Data VARIANT type for VARIANT type for
Type Scalar Data Array Data Comments
double A real 1-by-1 double A real Complex arrays are
matrix converts to multidimensional passed to and from
a VARIANT of type double matrix converts | compiled M-functions
VT _R8. A complex to a VARIANT of type using the MWComplex
1-by-1 double matrix VT_R8|VT_ARRAY. class. See “Class
converts to a VARIANT | A complex MWComplex” on page
of type VT_DISPATCH. multidimensional C-24.)
double matrix converts
to a VARIANT of type
VT _DISPATCH.
single A real 1-by-1 single A real Complex arrays are
matrix converts to a multidimensional passed to and from
VARIANT of type VT_R4. | single matrix converts | compiled M-functions
A complex 1-by-1 single | to a VARIANT of type using the MWComplex
matrix converts to VT _R4|VT_ARRAY. class. See “Class
a VARIANT of type A complex MWComplex” on page
VT_DISPATCH. multidimensional C-24.)
single matrix converts
to a VARIANT of type
VT _DISPATCH.
int8 A real 1-by-1 int8 A real Complex arrays are

matrix converts to a
VARIANT of type VT_I1.
A complex 1-by-1 int8
matrix converts to

a VARIANT of type
VT_DISPATCH.

multidimensional int8
matrix converts to

a VARIANT of type

VT _I1|VT_ARRAY.

A complex
multidimensional int8
matrix converts to

a VARIANT of type

VT _DISPATCH.

passed to and from
compiled M-functions
using the MWComplex
class. See “Class
MWComplex” on page
C-24.)
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MATLAB to COM VARIANT Conversion Rules (Continued)

MATLAB Data VARIANT type for VARIANT type for
Type Scalar Data Array Data Comments
uint8 A real 1-by-1 uint8 A real Complex arrays are
matrix converts to multidimensional passed to and from
a VARIANT of type uint8 matrix converts | compiled M-functions
VT UI1. A complex to a VARIANT of type using the MWComplex
1-by-1 uint8 matrix VT_UI1|VT_ARRAY.A class. See “Class
converts to a VARIANT | complex MWComplex” on page
of type VT_DISPATCH. multidimensional C-24.)
uint8 matrix converts
to a VARIANT of type
VT _DISPATCH.
int16 A real 1-by-1 int16 A real Complex arrays are
matrix converts to a multidimensional passed to and from
VARIANT of type VT_I2. | int16 matrix converts | compiled M-functions
A complex 1-by-1 int16 | to a VARIANT of type using the MWComplex
matrix converts to VT _I2|VT_ARRAY. class. See “Class
a VARIANT of type A complex MWComplex” on page
VT_DISPATCH. multidimensional C-24.)
int16 matrix converts
to a VARIANT of type
VT _DISPATCH.
uint16 A real 1-by-1 uint16 A real Complex arrays are
matrix converts to multidimensional passed to and from

a VARIANT of type
VT_UI2. A complex
1-by-1 uint16 matrix
converts to a VARIANT
of type VT_DISPATCH.

uint16 matrix converts
to a VARIANT of type
VT_UI2|VT_ARRAY.

A complex
multidimensional
uint16 matrix converts
to a VARIANT of type
VT _DISPATCH.

compiled M-functions
using the MWComplex
class. See “Class
MWComplex” on page
C-24.)
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MATLAB to COM VARIANT Conversion Rules (Continued)

MATLAB Data VARIANT type for VARIANT type for
Type Scalar Data Array Data Comments
int32 A 1-by-1 int32 matrix | A multidimensional Complex arrays are
converts to a VARIANT of | int32 matrix converts | passed to and from
type VT_I4. A complex | to a VARIANT of type compiled M-functions
1-by-1 int32 matrix VT_I4|VT_ARRAY. using the MWComplex
converts to a VARIANT | A complex class. See “Class
of type VT_DISPATCH. multidimensional MWComplex” on page
int32 matrix converts | C-24.)
to a VARIANT of type
VT_DISPATCH.
uint32 A 1-by-1 uint32 matrix | A multidimensional Complex arrays are

converts to a VARIANT of
type VT_UI4. A complex
1-by-1 uint32 matrix
converts to a VARIANT
of type VT_DISPATCH.

uint32 matrix converts
to a VARIANT of type
VT _UI4|VT_ARRAY.

A complex
multidimensional
uint32 matrix converts
to a VARIANT of type
VT_DISPATCH.

passed to and from
compiled M-functions
using the MWComplex
class. See “Class
MWComplex” on page
C-24.)

Function handle VT_EMPTY VT_EMPTY Not supported
Java class VT _EMPTY VT_EMPTY Not supported
User class VT _EMPTY VT_EMPTY Not supported
logical VT_Bool VT_Bool|VT_ARRAY

COM VARIANT to MATLAB Conversion Rules

MATLAB Data Type
(scalar or array
VARIANT Type data) Comments
VT _EMPTY N/A Empty array created.
VT _I1 int8
VT_UI1 uints
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COM VARIANT to MATLAB Conversion Rules (Continued)

MATLAB Data Type
(scalar or array

VARIANT Type data) Comments

VT_I2 int16

VT_UI2 uinti16

VT_I4 int32

VT _UI4 uint32

VT_R4 single

VT_R8 double

VT_CY double

VT_BSTR char A VARIANT of type VT_BSTR converts to a
1-by-LL MATLAB char array, where L =
the length of the string to be converted.
A VARIANT of type VT_BSTR|VT_ARRAY
converts to a MATLAB cell array of 1-by-L
char arrays.

VT_ERROR int32

VT_DATE double 1. VARIANT dates are stored as doubles
starting at midnight Dec. 31, 1899.
MATLAB dates are stored as doubles
starting at 0/0/00 00:00:00. Therefore, a
VARIANT date of 0.0 maps to a MATLAB
numeric date of 693960.0. VARIANT
dates are converted to MATLAB double
types and incremented by 693960.0.
2. VARIANT dates can be optionally
converted to strings. See “Data Conversion
Flags” on page B-13 for more information
on type coercion.

VT_INT int32

VT_UINT unit32

VT_DECIMAL double
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COM VARIANT to MATLAB Conversion Rules (Continued)

VARIANT Type

MATLAB Data Type
(scalar or array
data)

Comments

VT_BOOL

logical

VT_DISPATCH

(varies)

IDispatch* pointers are treated within
the context of what they point to. Objects
must be supported types with known data
extraction and conversion rules, or expose
a generic "Value property that points to a
single VARIANT type. Data extracted from
an object is converted based upon the rules
for the particular VARIANT obtained.

Currently, support exists for Excel Range
objects as well as Excel Builder types
MWStruct, MWComplex, MWSparse, and
MWArg. See “Utility Library Classes” on
page C-3 for information on Excel Builder

types.

<anything>|VT_BYREF

(varies)

Pointers to any of the basic types are
processed according to the rules for what
they point to. The resulting MATLAB
array contains a deep copy of the values.

<anything>|VT_ARRAY

(varies)

Multidimensional VARIANT arrays convert
to multidimensional MATLAB arrays, each
element converted according to the rules for
the basic types. Multidimensional VARIANT
arrays of type VT_VARIANT |VT_ARRAY
convert to multidimensional cell arrays,
each cell converted according to the rules
for that specific type.

Array Formatting Flags

Excel Builder components have flags that control how array data is formatted
in both directions. Generally, you should develop client code that matches the
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intended inputs and outputs of the MATLAB functions with the corresponding
methods on the compiled COM objects, in accordance with the rules listed in
MATLAB to COM VARIANT Conversion Rules on page B-5 and COM VARIANT
to MATLAB Conversion Rules on page B-9. In some cases this is not possible,
for example, when existing MATLAB code is used in conjunction with a
third-party product like Excel.

The following table shows the array formatting flags.

Array Formatting Flags

Flag Description

InputArrayFormat Defines the array formatting rule used on input arrays.
An input array is a VARIANT array, created

by the client, sent as an input parameter

to a method call on a compiled COM object.

Valid values for this flag are mwArrayFormatAsIs,
mwArrayFormatMatrix, and mwArrayFormatCell.

mwArrayFormatAsIs passes the array unchanged.

mwArrayFormatMatrix (default) formats all arrays

as matrices. When the input VARIANT is of type
VT_ARRAY | type, where type is any numeric type,
this flag has no effect. When the input VARIANT is of
type VT_VARIANT |VT_ARRAY, VARIANTSs in the array are
examined. If they are single-valued and homogeneous
in type, a MATLAB matrix of the appropriate type is
produced instead of a cell array.

mwArrayFormatCell interprets all arrays as MATLAB
cell arrays.

InputArrayIndFlag Sets the input array indirection level used with the
InputArrayFormat flag (applicable only to nested arrays,
i.e., VARIANT arrays of VARIANTs, which themselves are
arrays). The default value for this flag is zero, which
applies the InputArrayFormat flag to the outermost
array. When this flag is greater than zero, e.g., equal

to N, the formatting rule attempts to apply itself to the
Nth level of nesting.
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Array Formatting Flags (Continued)

Flag Description

OutputArrayFormat Defines the array formatting rule used on output arrays.
An output array is a MATLAB array, created by the
compiled COM object, sent as an output parameter
from a method call to the client. The values for this
flag, mwArrayFormatAsIs, mwArrayFormatMatrix, and
mwArrayFormatCell, cause the same behavior as the
corresponding InputArrayFormat flag values.

OutputArrayIndFlag (Applies to nested cell arrays only.) Output array
indirection level used with the OutputArrayFormat flag.
This flag works exactly like InputArrayIndFlag.

AutoResizeOQutput (Applies to Excel ranges only.) When the target output
from a method call is a range of cells in an Excel
worksheet and the output array size and shape is not
known at the time of the call, set this flag to True to
resize each Excel range to fit the output array.

TransposeOutput Set this flag to True to transpose the output arguments.
Useful when calling an Excel Builder component from
Excel where the MATLAB function returns outputs as
row vectors, and you want the data in columns.

Data Conversion Flags

Excel Builder components contain flags to control the conversion of certain
VARIANT types to MATLAB types.

CoerceNumericToType

This flag tells the data converter to convert all numeric VARIANT data

to one specific MATLAB type. VARIANT type codes affected by this flag

are VT_I1, VT _UI1, VT _I2, VT _UI2, VT_I4, VT _UI4, VT_R4, VT_R8, VT_CY,
VT_DECIMAL, VT_INT, VT_UINT, VT_ERROR, VT_BOOL, and VT_DATE. Valid values
for this flag are mwTypeDefault, mwTypeChar, mwTypeDouble, mwTypeSingle,
mwTypeLogical, mwTypeInt8, mwTypeUint8, mwTypeInt16, mwTypeUint16,
mwTypeInt32, and mwTypeUint32. The default for this flag, mwTypeDefault,
converts numeric data according to the rules listed in .
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InputDateFormat

This flag tells the data converter how to convert VARIANT dates to MATLAB
dates. Valid values for this flag are mwDateFormatNumeric (default) and
mwDateFormatString. The default converts VARIANT dates according

to the rule listed in VARIANT Type Codes Supported on page B-3. The
mwDateFormatString flag converts a VARIANT date to its string representation.
This flag only affects VARIANT type code VT_DATE.

OutputAsDate As Boolean

This flag instructs the data converter to process an output argument as a
date. By default, numeric dates that are output parameters from compiled
MATLAB functions are passed as Doubles that need to be decremented by
the COM date bias (693960) as well as coerced to COM dates. Set this flag to
True to convert all output values of type Double.

DateBias As Long

This flag sets the date bias for performing COM to MATLAB numeric date
conversions. The default value of this property is 693960, which represents
the difference between the COM Date type and MATLAB numeric dates.
This flag allows existing MATLAB code that already performs the increment
of numeric dates by 693960 to be used unchanged with Excel Builder
components. To process dates with such code, set this property to 0.
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Referencing the Utility Classes

C-2

This section describes the MWComUtil library provided with MATLAB Builder
for Excel. This library is freely distributable and includes several functions
used in array processing, as well as type definitions used in data conversion.
This library is contained in the file mwcomutil.d11. It must be registered once
on each machine that uses Excel Builder components.

Register the MWComUtil library at the DOS command prompt with the
command

mwregsvr mwcomutil.dll

The MWComUtil library includes seven classes (see “Utility Library Classes” on
page C-3) and three enumerated types (see “Enumerations” on page C-31).
Before using these types, you must make explicit references to the MWComUtil
type libraries in the Visual Basic IDE. To do this select Tools>References
from the main menu of the VB editor. The References dialog box appears
with a scrollable list of available type libraries. From this list select
MWComUtil 1.0 Type Library and click OK.
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Utility Library Classes

The MATLAB Builder for Excel Utility library provides several classes:

“Class MWUtil” on page C-3
“Class MWFlags” on page C-10
“Class MWStruct” on page C-16
“Class MWField” on page C-23
“Class MWComplex” on page C-24
“Class MWSparse” on page C-26
“Class MWArg” on page C-29

Class MWUIil

The MWUtil class contains a set of static utility methods used in array
processing and application initialization. This class is implemented internally
as a singleton (only one global instance of this class per instance of Excel). It
is most efficient to declare one variable of this type in global scope within each
module that uses it. The methods of MWUtil are

“Sub MWInitApplication(pApp As Object)” on page C-3
“Sub MWPack(pVarArg, [Var0], [Varl], ... ,[Var31])” on page C-5

“Sub MWUnpack(VarArg, [nStartAt As Long], [bAutoResize As Boolean =
False], [pVar0], [pVarl], ..., [pVar31])” on page C-6

“Sub MWDate2VariantDate(pVar)” on page C-8

The function prototypes use Visual Basic syntax.

Sub MWinitApplication(pApp As Obiject)

Initializes the library with the current instance of Excel.
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Parameters.
Argument Type Description
pApp Object A valid reference to
the current Excel
application

Return Value. None.

Remarks. This function must be called once for each session of Excel that
uses Excel Builder components. An error is generated if a method call is
made to a member class of any Excel Builder component, and the library has
not been initialized.

Example. This Visual Basic sample initializes the MWComUtil library with
the current instance of Excel. A global variable of type Object named MCLUtil
holds an instance of the MWUtil class, and another global variable of type
Boolean named bModuleInitialized stores the status of the initialization
process. The private subroutine InitModule () creates an instance of the
MWComUtil class and calls the MWInitApplication method with an argument
of Application. Once this function succeeds, all subsequent calls exit without
recreating the object.

Dim MCLUtil As Object
Dim bModuleInitialized As Boolean

Private Sub InitModule()
If Not bModuleInitialized Then
On Error GoTo Handle Error
If MCLUtil Is Nothing Then
Set MCLUtil = CreateObject("MWComUtil.MWUtil")
End If
Call MCLUtil.MWInitApplication(Application)
bModuleInitialized = True
Exit Sub
Handle_Error:
bModuleInitialized = False
End If
End Sub
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Sub MWPack(pVarArg, [Var0], [Varl], ... ,[Var31])

Packs a variable length list of Variant arguments into a single Variant
array. This function is typically used for creating a varargin cell from a list
of separate inputs. Each input in the list is added to the array only if it is
nonempty and nonmissing. (In Visual Basic, a missing parameter is denoted
by a Variant type of vbError with a value of &H80020004.)

Parameters.
Argument Type Description
pVvarArg Variant Receives the resulting
array
[Var0], [Varil], ... |Variant Optional list of

Variants to pack into
the array. From 0 to

32 arguments can be

passed.

Return Value. None.

Remarks. This function always frees the contents of pVarArg before
processing the list.

Example. This example uses MWPack in a formula function to produce a
varargin cell to pass as an input parameter to a method compiled from a
MATLAB function with the signature

function y = mysum(varargin)
y = sum([varargin{:}1);

The function returns the sum of the elements in varargin. Assume that this
function is a method of a class named myclass that is included in a component
named mycomponent with a version of 1.0. The Visual Basic function allows
up to 10 inputs, and returns the result y. If an error occurs, the function
returns the error string. This function assumes that MWInitApplication
has been previously called.
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Function mysum(Optional VO As Variant, _
Optional V1 As Variant, _
Optional V2 As Variant, _
Optional V3 As Variant, _
Optional V4 As Variant, _
Optional V5 As Variant, _
Optional V6 As Variant, _
Optional V7 As Variant, _
Optional V8 As Variant, _
Optional V9 As Variant) As Variant

Dim y As Variant

Dim varargin As Variant

Dim aClass As Object

Dim auUtil As Object

On Error Goto Handle_Error
Set aClass = CreateObject("mycomponent.myclass.1 _0")
Set aUtil = CreateObject("MWComUtil.MWUtil")
Call auUtil.MwPack(varargin,vo,vi,v2,V3,v4,V5,V6,V7,V8,V9)
Call aClass.mysum(1, y, varargin)
mysum =y
Exit Function
Handle_Error:
mysum = Err.Description
End Function

Sub MWUnpack(VarArg, [nStartAt As Long], [bAutoResize As
Boolean = False], [pVar0], [pVarl], ..., [pVar31])

Unpacks an array of Variants into individual Variant arguments. This
function provides the reverse functionality of MWPack and is typically used to
process a varargout cell into individual Variants.
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Parameters.

Argument

Type

Description

VarArg

Variant

Input array of Variants
to be processed

nStartAt

Long

Optional starting
index (zero-based)

in the array to begin
processing. Default = 0.

bAutoResize

Boolean

Optional auto-resize
flag. If this flag is
True, any Excel range
output arguments

are resized to fit the
dimensions of the
Variant to be copied.
The resizing process is
applied relative to the
upper left corner of the
supplied range. Default
= False.

[pVarO],[pVari],

Variant

Optional list of
Variants to receive the
array items contained
in VarArg. From 0 to
32 arguments can be
passed.

Return Value. None.

Remarks. This function can process a Variant array in one single call or
through multiple calls using the nStartAt parameter.

Example. This example uses MWUnpack to process a varargout cell into
several Excel ranges, while auto-resizing each range. The varargout
parameter is supplied from a method that has been compiled from the

MATLAB function.
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function varargout = randvectors

for

end

i=1:nargout
varargout{i} = rand(i,1);

This function produces a sequence of nargout random column vectors, with
the length of the ith vector equal to i. Assume that this function is included in
a class named myclass that is included in a component named mycomponent
with a version of 1.0. The Visual Basic subroutine takes no arguments and
places the results into Excel columns starting at A1, B1, C1, and D1. If an
error occurs, a message box displays the error text. This function assumes
that MWInitApplication has been previously called.

Sub GenVectors()

Dim
Dim
Dim
Dim
Dim
Dim
Dim

aClass As Object
aUtil As Object
v As Variant
R1 As Range
R2 As Range
R3 As Range
R4 As Range

On Error GoTo Handle Error

Set
Set
Set
Set
Set
Set

aClass = CreateObject("mycomponent.myclass.1_0")
aUtil = CreateObject("MWComUtil.MWUtil")

R1 = Range("A1")

R2 Range("B1")

R3 Range("C1")

R4 = Range("D1")

Call aClass.randvectors(4, v)
Call auUtil.MwWUnpack(v,0,True,R1,R2,R3,R4)
Exit Sub
Handle_Error:
MsgBox (Err.Description)

End Sub

Sub MWDate2VariantDate(pVar)
Converts output dates from MATLAB to Variant dates.
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Parameters.
Argument Type Description
pvar Variant Variant to be converted

Return Value. None.

Remarks. MATLAB handles dates as double-precision floating-point
numbers with 0.0 representing 0/0/00 00:00:00 (See “Data Conversion Rules”
on page B-2 for more information on conversion between MATLAB and
COM date values). By default, numeric dates that are output parameters
from compiled MATLAB functions are passed as Doubles that need to be
decremented by the COM date bias as well as coerced to COM dates. The
MWDate2VariantDate method performs this transformation and additionally
converts dates in string form to COM date types.

Example. This example uses MWDate2VariantDate to process numeric dates
returned from a method compiled from the following MATLAB function.

function x = getdates(n, inc)
y = now,
for i=1:n
x(i,1) =y + (i-1)*inc;
end

This function produces an n-length column vector of numeric values
representing dates starting from the current date and time with each element
incremented by inc days. Assume that this function is included in a class
named myclass that is included in a component named mycomponent with

a version of 1.0. The subroutine takes an Excel range and a Double as
inputs and places the generated dates into the supplied range. If an error
occurs, a message box displays the error text. This function assumes that
MWInitApplication has been previously called.

Sub GenDates(R As Range, inc As Double)
Dim aClass As Object
Dim auUtil As Object

On Error GoTo Handle Error
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Set aClass = CreateObject("mycomponent.myclass.1_0")
Set aUtil = CreateObject("MWComUtil.MWUtil")
Call aClass.getdates(1, R, R.Rows.Count, inc)
Call autil.MwDate2VariantDate(R)
Exit Sub
Handle_Error:
MsgBox (Err.Description)
End Sub

Class MWFlags

The MWFlags class contains a set of array formatting and data conversion
flags (See “Data Conversion Rules” on page B-2 for more information on
conversion between MATLAB and COM Automation types). All Excel Builder
components contain a reference to an MWFlags object that can modify data
conversion rules at the object level. This class contains these properties:

® “Property ArrayFormatFlags As MWArrayFormatFlags” on page C-10

e “Property DataConversionFlags As MWDataConversionFlags” on page
C-13

® “Sub Clone(ppFlags As MWFlags)” on page C-15

Property ArrayFormatFlags As MWArrayFormatFlags

The ArrayFormatFlags property controls array formatting (as a matrix
or a cell array) and the application of these rules to nested arrays. The
MWArrayFormatFlags class is a noncreatable class accessed through an
MWFlags class instance. This class contains six properties:

* “Property InputArrayFormat As mwArrayFormat” on page C-11

* “Property InputArrayIndFlag As Long” on page C-11

* “Property OutputArrayFormat As mwArrayFormat” on page C-12

® “Property OutputArrayIndFlag As Long” on page C-12

® “Property AutoResizeOutput As Boolean” on page C-13

® “Property TransposeOutput As Boolean” on page C-13
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Property InputArrayFormat As mwArrayFormat. This property of type
mwArrayFormat controls the formatting of arrays passed as input parameters
to Excel Builder class methods. The default value is mwArrayFormatMatrix.
The behaviors indicated by this flag are listed in the next table.

Array Formatting Rules for Input Arrays

Value Behavior

mwArrayFormatAsIs Converts arrays according to the
default conversion rules listed in .

mwArrayFormatCell Coerces all arrays into cell arrays.
Input scalar or numeric array
arguments are converted to cell
arrays with each cell containing a
scalar value for the respective index.

mwArrayFormatMatrix Coerces all arrays into matrices.
When an input argument is
encountered that is an array of
Variants (the default behavior is
to convert it to a cell array), the
data converter converts this array
to a matrix if each Variant is
single valued, and all elements are
homogeneous and of a numeric type.
If this conversion is not possible,
creates a cell array.

Property InputArrayindFlag As Long. This property governs the level at
which to apply the rule set by the InputArrayFormat property for nested
arrays (an array of Variants is passed and each element of the array is an
array itself). It is not necessary to modify this flag for varargin parameters.
The data conversion code automatically increments the value of this flag by
1 for varargin cells, thus applying the InputArrayFormat flag to each cell
of a varargin parameter. The default value is 0.
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Property OutputArrayFormat As mwArrayFormat. This property of type
mwArrayFormat controls the formatting of arrays passed as output parameters
to Excel Builder class methods. The default value is mwArrayFormatAsIs. The
behaviors indicated by this flag are listed in the next table.

Array Formatting Rules for Output Arrays

Value Behavior

mwArrayFormatAsIs Converts arrays according to the
default conversion rules listed
in MATLAB to COM VARIANT
Conversion Rules on page B-5.

mwArrayFormatMatrix Coerces all arrays into matrices.
When an output cell array argument
is encountered (the default behavior
converts it to an array of Variants),
the data converter converts this
array to a Variant that contains a
simple numeric array if each cell is
single valued, and all elements are
homogeneous and of a numeric type.
If this conversion is not possible, an
array of Variants is created.

mwArrayFormatCell Coerces all output arrays into
arrays of Variants. Output scalar
or numeric array arguments are
converted to arrays of Variants,
each Variant containing a scalar
value for the respective index.

Property OutputArrayindFlag As Long. This property is similar to the
InputArrayIndFalg property, as it governs the level at which to apply the
rule set by the OutputArrayFormat property for nested arrays. As with
the input case, this flag is automatically incremented by 1 for a varargout
parameter. The default value of this flag is 0.
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Property AutoResizeOutput As Boolean. This flag applies to Excel ranges
only. When the target output from a method call is a range of cells in an Excel
worksheet, and the output array size and shape is not known at the time of the
call, setting this flag to True instructs the data conversion code to resize each
Excel range to fit the output array. Resizing is applied relative to the upper
left corner of each supplied range. The default value for this flag is False.

Property TransposeOutput As Boolean. Setting this flag to True
transposes the output arguments. This flag is useful when processing an
output parameter from a method call on an Excel Builder component, where
the MATLAB function returns outputs as row vectors, and you desire to place
the data into columns. The default value for this flag is False.

Property DataConversionFlags As MWDataConversionFlags
The DataConversionFlags property controls how input variables are
processed when type coercion is needed. The MWDataConversionFlags class
is a noncreatable class accessed through an MWFlags class instance. This
class contains these properties:

® “Property CoerceNumericToType As mwDataType” on page C-13
® “Property InputDateFormat As mwDateFormat” on page C-13

® “PropertyOutputAsDate As Boolean” on page C-15

e “PropertyDateBias As Long” on page C-15

Property CoerceNumericToType As mwDataType. This property
converts all numeric input arguments to one specific MATLAB type. This
flag is useful is when variables maintained within the Visual Basic code are
different types, e.g., Long, Integer, etc., and all variables passed to the
compiled MATLAB code must be doubles. The default value for this property
is mwTypeDefault, which uses the default rules in COM VARIANT to MATLAB
Conversion Rules on page B-9.

Property InputDateFormat As mwDateFormat. This property converts
dates passed as input parameters to method calls on Excel Builder classes.
The default value is mwDateFormatNumeric. The behaviors indicated by this
flag are shown in the following table..
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Conversion Rules for Input Dates

Value Behavior

mwDateFormatNumeric Convert dates to numeric values as
indicated by the rule listed in COM
VARIANT to MATLAB Conversion
Rules on page B-9.

mwDateFormatString Convert input dates to strings.

Example. This example uses data conversion flags to reshape the output
from a method compiled from a MATLAB function that produces an output
vector of unknown length.

function p = myprimes(n)
if length(n)~=1, error('N must be a scalar'); end
if n <2, p = zeros(1,0); return, end

p =1:2:n;
q = length(p);
p(1) = 2;

for k = 3:2:sqrt(n)
if p((k+1)/2)
p(((k*k+1)/2):k:q) = 0;
end
end

p = (p(p>0));

This function produces a row vector of all the prime numbers between 0 and
n. Assume that this function is included in a class named myclass that

is included in a component named mycomponent with a version of 1.0. The
subroutine takes an Excel range and a Double as inputs, and places the
generated prime numbers into the supplied range. The MATLAB function
produces a row vector, although you want the output in column format. It also
produces an unknown number of outputs, and you do not want to truncate
any output. To handle these issues, set the TransposeOutput flag and the
AutoResizeOutput flag to True. In previous examples, the Visual Basic
CreateObject function creates the necessary classes. This example uses an
explicit type declaration for the aClass variable. As with previous examples,
this function assumes that MWInitApplication has been previously called.
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Sub GenPrimes(R As Range, n As Double)
Dim aClass As mycomponent.myclass

On Error GoTo Handle_Error
Set aClass = New mycomponent.myclass
aClass.MWFlags.ArrayFormatFlags.AutoResizeQutput = True
aClass.MWFlags.ArrayFormatFlags.TransposeOutput = True
Call aClass.myprimes(1, R, n)
Exit Sub

Handle_Error:
MsgBox (Err.Description)

End Sub

PropertyOutputAsDate As Boolean. This property processes an output
argument as a date. By default, numeric dates that are output parameters
from compiled MATLAB functions are passed as Doubles that need to be
decremented by the COM date bias (693960) as well as coerced to COM dates.
Set this flag to True to convert all output values of type Double.

PropertyDateBias As Long. This property sets the date bias for performing
COM to MATLAB numeric date conversions. The default value of this
property is 693960, representing the difference between the COM Date type
and MATLAB numeric dates. This flag allows existing MATLAB code that
already performs the increment of numeric dates by 693960 to be used
unchanged with Excel Builder components. To process dates with such code,
set this property to 0.

Sub Clone(ppFlags As MWFlags)
Creates a copy of an MWFlags object.

Parameters.
Argument Type Description
ppFlags MWFlags Reference to an

uninitialized MWFlags
object that receives the

copy
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Return Value. None

Remarks. Clone allocates a new MWFlags object and creates a deep copy of
the object’s contents. Call this function when a separate object is required
instead of a shared copy of an existing object reference.

Class MWStruct

The MWStruct class passes or receives a Struct type to or from a compiled
class method. This class contains seven properties/methods:

® “Sub Initialize([varDims], [varFieldNames])” on page C-16

e “Property Item([i0], [i1], ..., [i31]) As MWField” on page C-18

® “Property NumberOfFields As Long” on page C-20

¢ “Property NumberOfDims As Long” on page C-20

® “Property Dims As Variant” on page C-21

® “Property FieldNames As Variant” on page C-21

® “Sub Clone(ppStruct As MWStruct)” on page C-22

Sub Initialize([varDims], [varFieldNames])

This method allocates a structure array with a specified number and size of
dimensions and a specified list of field names.

Parameters.
Argument Type Description
varDims Variant Optional array of
dimensions
varFieldNames Variant Optional array of field
names

Return Value. None.
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Remarks. When created, an MWStruct object has a dimensionality of 1-by-1
and no fields. The Initialize method dimensions the array and adds a set of
named fields to each element. Each time you call Initialize on the same
object, it is redimensioned. If you do not supply the varDims argument, the
existing number and size of the array’s dimensions unchanged. If you do not
supply the varFieldNames argument, the existing list of fields is not changed.
Calling Initialize with no arguments leaves the array unchanged.

Example. The following Visual Basic code illustrates use of the Initialize
method to dimension struct arrays.

Sub foo ()
Dim x As MWStruct
Dim y As MWStruct

On Error Goto Handle_Error

'Create 1X1 struct arrays with no fields for x, and y
Set x = new MWStruct

Set y = new MWStruct

"Initialize x to be 2X2 with fields "red", "green", and "blue"
Call x.Initialize(Array(2,2), Array('red", "green", "blue"))
'Initialize y to be 1X5 with fields "name" and "age"

Call y.Initialize(5, Array("name", "age"))

'Re-dimension x to be 3X3 with the same field names
Call x.Initialize(Array(3,3))

'Add a new field to y
Call y.Initialize(, Array('name", "age", "salary"))

Exit Sub
Handle_Error:

MsgBox (Err.Description)
End Sub
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Property ltem([i0], [i1], ..., [(31]) As MWField
The Item property is the default property of the MWStruct class. This property
is used to set/get the value of a field at a particular index in the structure

array.
Parameters.
Argument Type Description
i0,it, ..., i31 Variant Optional index

arguments. Between 0
and 32 index arguments
can be entered. To
reference an element
of the array, specify all
indexes as well as the
field name.

Remarks. When accessing a named field through this property, you must
supply all dimensions of the requested field as well as the field name. This
property always returns a single field value, and generates a bad index error
if you provide an invalid or incomplete index list. Index arguments have
four basic formats:

® Field name only
This format may be used only in the case of a 1-by-1 structure array and
returns the named field’s value. For example:

x("red") = 0.2
x("green") = 0.4
X("blue") = 0.6

In this example, the name of the Item property was neglected. This is
possible since the Item property is the default property of the MWStruct

class. In this case the two statements are equivalent:

x.Item("red") = 0.2
Xx("red") = 0.2

® Single index and field name
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This format accesses array elements through a single subscripting notation. A
single numeric index n followed by the field name returns the named field on
the nth array element, navigating the array linearly in column-major order.
For example, consider a 2-by-2 array of structures with fields "red", "green"
,and "blue" stored in a variable x. These two statements are equivalent:

y = x(2, "red")
y = x(2, 1, "red")

e All indices and field name

This format accesses an array element of an multidimensional array by
specifying n indices. These statements access all four of the elements of the
array in the previous example:

For I From 1 To 2
For J From 1 To 2
r(I, J) = x(I, J, "red")
g(I, J) = x(I, J, "green")
b(I, J) = x(I, J, "blue")

Next
Next

® Array of indices and field name
This format accesses an array element by passing an array of indices and a

field name. The next example rewrites the previous example using an index
array:

Dim Index(1 To 2) As Integer

For I From 1 To 2

Index(1) =1
For J From 1 To 2
Index(2) = J
r(I, J) = x(Index, "red")
g(I, J) = x(Index, "green")
b(I, J) = x(Index, "blue")
Next

Next
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With these four formats, the Item property provides a very flexible indexing
mechanism for structure arrays. Also note:

® You can combine the last two indexing formats. Several index arguments
supplied in either scalar or array format are concatenated to form one
index set. The combining stops when the number of dimensions has been
reached. For example:

Dim Index1(1 To 2) As Integer
Dim Index2(1 To 2) As Integer

Index1(1) = 1
Index1(2) = 1
Index2(1) = 3
Index2(2) = 2

x(Index1, Index2, 2, "red") = 0.5
The last statement resolves to
x(1, 1, 3, 2, 2, "red") = 0.5

® The field name must be the last index in the list. The following statement
produces an error:

y = x("blue", 1, 2)
* TField names are case sensitive.
Property NumberOfFields As Long

The read-only NumberOfFields property returns the number of fields in the
structure array.

Property NumberOfDims As Long
The read-only NumberOfDims property returns the number of dimensions in
the struct array.
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Property Dims As Variant

The read-only Dims property returns an array of length Number0fDims that
contains the size of each dimension of the struct array.

Property FieldNames As Variant

The read-only FieldNames property returns an array of length
NumberOfFields that contains the field names of the elements of the structure
array.

Example. The next Visual Basic code sample illustrates how to access a
two-dimensional structure array’s fields when the field names and dimension
sizes are not known in advance.

Sub foo ()
Dim x As MWStruct
Dim Dims as Variant
Dim FieldNames As Variant

On Error Goto Handle Error

'... Call a method that returns an MWStruct in x
Dims = x.Dims
FieldNames = x.FieldNames
For I From 1 To Dims(1)
For J From 1 To Dims(2)
For K From 1 To x.NumberOfFields
y = x(I,J,FieldNames(K))
" ... Do something with y
Next
Next
Next
Exit Sub
Handle_Error:
MsgBox (Err.Description)
End Sub
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Sub Clone(ppStruct As MWStruct)
Creates a copy of an MWStruct object.

Parameters.
Argument Type Description
ppStruct MWStruct Reference to an

uninitialized MWStruct
object to receive the

copy

Return Value. None

Remarks. Clone allocates a new MWStruct object and creates a deep copy
of the object’s contents. Call this function when a separate object is required
instead of a shared copy of an existing object reference.

Example. The following Visual Basic example illustrates the difference
between assignment and Clone for MWStruct objects.

Sub foo
Dim
Dim
Dim

On E
Set
x1("
x1("

'Set
Set

()
x1 As MWStruct

x2 As MWStruct
x3 As MWStruct

rror Goto Handle_ Error
x1 = new MWStruct
name") = "John Smith"
age") = 35

reference of x1 to x2
x2 = x1

'Create new object for x3 and copy contents of x1 into it
Call x1.Clone(x3)

'x2's "age" field is also modified

x1("

age") = 50

'x3's "age" field unchanged
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Exit Sub
Handle_Error:

MsgBox (Err.Description)
End Sub

Class MWField

The MWField class holds a single field reference in an MWStruct object. This
class is noncreatable and contains four properties/methods:

® “Property Name As String” on page C-23

® “Property Value As Variant” on page C-23

e “Property MWFlags As MWFlags” on page C-23

e “Sub Clone(ppField As MWField)” on page C-23

Property Name As String
The name of the field (read only).

Property Value As Variant

Stores the field’s value (read/write). The Value property is the default
property of the MWField class. The value of a field can be any type that is
coercible to a Variant, as well as object types.

Property MWFlags As MWFlags

Stores a reference to an MWFlags object. This property sets or gets the array
formatting and data conversion flags for a particular field. Each field in a
structure has its own MWFlags property. This property overrides the value of
any flags set on the object whose methods are called.

Sub Clone(ppField As MWField)
Creates a copy of an MWField object.
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Parameters.
Argument Type Description
ppField MWField Reference to an

uninitialized MWField
object to receive the

copy

Return Value. None.

Remarks. Clone allocates a new MWField object and creates a deep copy of
the object’s contents. Call this function when a separate object is required
instead of a shared copy of an existing object reference.

Class MWComplex

The MWComplex class passes or receives a complex numeric array into or from
a compiled class method. This class contains four properties/methods:

* “Property Real As Variant” on page C-24

® “Property Imag As Variant” on page C-24

* “Property MWFlags As MWFlags” on page C-25

® “Sub Clone(ppComplex As MWComplex)” on page C-26

Property Real As Variant

Stores the real part of a complex array (read/write). The Real property is the
default property of the MWComplex class. The value of this property can be any
type coercible to a Variant, as well as object types, with the restriction that
the underlying array must resolve to a numeric matrix (no cell data allowed).
Valid Visual Basic numeric types for complex arrays include Byte, Integer,
Long, Single, Double, Currency, and Variant/vbDecimal.

Property Imag As Variant

Stores the imaginary part of a complex array (read/write). The Imag property
is optional and can be Empty for a pure real array. If the Imag property is
nonempty and the size and type of the underlying array do not match the size
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and type of the Real property’s array, an error results when the object is
used in a method call.

Example. The following Visual Basic code creates a complex array with
the following entries:

x = [ 1+1 1+2i
2+i 2+21 ]
Sub foo()
Dim x As MWComplex
Dim rval(1 To 2, 1 To 2) As Double
Dim ival(1 To 2, 1 To 2) As Double

On Error Goto Handle_Error
For I =1 To 2
For d =1 To 2
rval(I,dJ) =1
ival(I,J)

1}
c

Next
Next
Set x = new MWComplex
x.Real = rval
x.Imag = ival

Exit Sub
Handle_Error:

MsgBox (Err.Description)
End Sub

Property MWFlags As MWFlags

Stores a reference to an MWFlags object. This property sets or gets the array
formatting and data conversion flags for a particular complex array. Each
MWComplex object has its own MWFlags property. This property overrides the
value of any flags set on the object whose methods are called.
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Sub Clone(ppComplex As MWComplex)
Creates a copy of an MWComplex object.

Parameters.
Argument Type Description
ppComplex MWComplex Reference to

an uninitialized
MWComplex object to
receive the copy

Return Value. None

Remarks. Clone allocates a new MWComplex object and creates a deep copy
of the object’s contents. Call this function when a separate object is required
instead of a shared copy of an existing object reference.

Class MWSparse

The MWSparse class passes or receives a two-dimensional sparse numeric array
into or from a compiled class method. This class has seven properties/methods:

“Property NumRows As Long” on page C-26

e “Property NumColumns As Long” on page C-27

* “Property RowlIndex As Variant” on page C-27

® “Property ColumnIndex As Variant” on page C-27
® “Property Array As Variant” on page C-27

* “Property MWFlags As MWFlags” on page C-27

® “Sub Clone(ppSparse As MWSparse)” on page C-28

Property NumRows As Long

Stores the row dimension for the array. The value of NumRows must be
nonnegative. If the value is zero, the row index is taken from the maximum
of the values in the RowIndex array.
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Property NumColumns As Long

Stores the column dimension for the array. The value of NumColumns must be
nonnegative. If the value is zero, the row index is taken from the maximum of
the values in the ColumnIndex array.

Property RowIndex As Variant

Stores the array of row indices of the nonzero elements of the array. The value
of this property can be any type coercible to a Variant, as well as object types,
with the restriction that the underlying array must resolve to or be coercible
to a numeric matrix of type Long. If the value of NumRows is nonzero and any
row index is greater than NumRows, a bad-index error occurs. An error also
results if the number of elements in the RowIndex array does not match the
number of elements in the Array property’s underlying array.

Property Columnindex As Variant

Stores the array of column indices of the nonzero elements of the array. The
value of this property can be any type coercible to a Variant, as well as object
types, with the restriction that the underlying array must resolve to or be
coercible to a numeric matrix of type Long. If the value of NumColumns is
nonzero and any column index is greater than NumColumns, a bad-index error
occurs. An error also results if the number of elements in the ColumnIndex
array does not match the number of elements in the Array property’s
underlying array.

Property Array As Variant

Stores the nonzero array values of the sparse array. The value of this property
can be any type coercible to a Variant, as well as object types, with the
restriction that the underlying array must resolve to or be coercible to a
numeric matrix of type Double or Boolean.

Property MWFlags As MWFlags

Stores a reference to an MWFlags object. This property sets or gets the array
formatting and data conversion flags for a particular sparse array. Each
MWSparse object has its own MWFlags property. This property overrides the
value of any flags set on the object whose methods are called.
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Sub Clone(ppSparse As MWSparse)

Creates a copy of an MWSparse object.

Parameters.
Argument Type Description
ppSparse MWSparse Reference to an

uninitialized MWSparse
object to receive the

copy

Return Value. None.

Remarks. Clone allocates a new MWSparse object and creates a deep copy
of the object’s contents. Call this function when a separate object is required
instead of a shared copy of an existing object reference.

Example. The following Visual Basic sample creates a 5-by-5 tridiagonal

sparse array with the following entries:

0o O
-1 0
2 -1
-1 2 .
0o -1

N =+ OO0O0o

-1
2
-1
0
0

Dim x As MWSparse

Dim rows(1 To 13) As Long
Dim cols(1 To 13) As Long
Dim vals(1 To 13) As Double
Dim I As Long, K As Long

On Error GoTo Handle Error

K =1

For I =1 To 4
rows(K) = I
cols(K) =1 + 1
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In =1

=1

In = 1

Next
rows (K)
cols(K) =5
vals (K)

Set x = New MWSparse
X.NumRows = 5
.NumColumns = 5
.RowIndex = rows
.ColumnIndex = cols

X
X
X
x.Array = vals

Exit Sub
Handle_Error:

MsgBox (Err.Description)
End Sub

Class MWArg

The MWArg class passes a generic argument into a compiled class method. This
class passes an argument for which the data conversion flags are changed for
that one argument. This class has three properties/methods:

® “Property Value As Variant” on page C-30

e “Property MWFlags As MWFlags” on page C-30

® “Sub Clone(ppArg As MWArg)” on page C-30
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Property Value As Variant

The Value property stores the actual argument to pass. Any type that can be
passed to a compiled method is valid for this property.

Property MWFlags As MWFlags

Stores a reference to an MWFlags object. This property sets or gets the array
formatting and data conversion flags for a particular argument. Each MWArg
object has its own MWFlags property. This property overrides the value of any
flags set on the object whose methods are called.

Sub Clone(ppArg As MWArg)
Creates a copy of an MWArg object.

Parameters.
Argument Type Description
pPpArg MWArg Reference to an

uninitialized MWArg
object to receive the

copy

Return Value. None.

Remarks. Clone allocates a new MWArg object and creates a deep copy of the
object’s contents. Call this function when a separate object is required instead
of a shared copy of an existing object reference.
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Enumerations

The MATLAB Builder for Excel Utility library provides three enumerations
(sets of constants):

¢ “Enum mwArrayFormat” on page C-31

¢ “Enum mwDataType” on page C-31

¢ “Enum mwDateFormat” on page C-32

Enum mwArrayFormat

The mwArrayFormat enumeration is a set of constants that denote an array
formatting rule for data conversion. lists the members of this enumeration.

mwArrayFormat Values

Constant Numeric Value Description

mwArrayFormatAsIs 0 Do not reformat the
array.

mwArrayFormatMatrix |1 Format the array as a
matrix.

mwArrayFormatCell 2 Format the array as a
cell array.

Enum mwDataType

The mwDataType enumeration is a set of constants that denote a MATLAB
numeric type. lists the members of this enumeration.

mwDataType Values

Constant Numeric Value MATLAB Type
mwTypeDefault 0 N/A
mwTypelLogical 3 logical
mwTypeChar 4 char
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mwDataType Values (Continued)

Constant Numeric Value MATLAB Type
mwTypeDouble 6 double
mwTypeSingle 7 single
mwTypeInt8 8 int8
mwTypeUint8 9 uint8
mwTypelInti16 10 int16
mwTypeUint16 11 uint16
mwTypeInt32 12 int32
mwTypeUint32 13 uint32

Enum mwDateFormat

The mwDateFormat enumeration is a set of constants that denote a formatting
rule for dates. lists the members of this enumeration.

mwDateFormat Values

Constant Numeric Value Description

mwDateFormatNumeric | O Format dates as
numeric values

mwDateFormatString 1 Format dates as strings

C-32
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D-2

This section provides a table showing errors you may encounter using
MATLAB Builder for Excel, probable causes for these errors, and suggested

solutions.

Note MATLAB Builder for Excel uses the MATLAB Compiler to generate
components. This means that you might see diagnostic messages from the
MATLAB Compiler. See the “Troubleshooting” section of the MATLAB
Compiler documentation for more information about those messages.

Excel Builder Errors and Suggested Solutions

Message

Probable Cause

Suggested Solution

MBUILD.BAT: Error: The chosen
compiler does not support building
COM objects.

The chosen compiler
does not support
building COM

Rerun mbuild -setup
and choose a supported
compiler.

objects.
Error in Usually caused by Open a DOS window,
component_name.class_name.1_0: Error |mwcomutil.dll not change directories to
getting data conversion flags. being registered. <matlab>\bin\win32
(<matlab> represents
the location of MATLAB
on your system), and
run the command
mwregsvr mwcomutil.dll.
Error in VBAProject: ActiveX 1. Project DLL is not | If the DLL is not registered,
component can't create object. registered. open a DOS window,
2. An incompatible (ihange dirgctorie.s to )
MATLAB DLL exists | ProJéctdir>idistrib
(<projectdir>
somewhere on the .
—— represents !:he location
of your project files),
and run the command:
mwregsvr <projectdll>.dll.
Error in VBAProject: Automation This usually occurs See Required Locations

error The specified module could
not be found.

if MATLAB is not on
the system path.

to Develop and Use
Components on page D-4
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Excel Builder Errors and Suggested Solutions (Continued)

Message

Probable Cause

Suggested Solution

LoadLibrary ("component_name_1_0.d11")
failed - The specified module could
not be found.

You may get this
error message while
registering the
project DLL from
the DOS prompt.
This usually occurs
if MATLAB is not on
the system path.

See Required Locations
to Develop and Use
Components on page D-4

Cannot recompile the M file xxxx
because it is already in the
library libmmfile.mlib.

The name you have
chosen for your M-file
duplicates the name
of an M-file already
in the library of
precompiled M-files.

Rename the M-file, choosing
a name that does not
duplicate the name of an
M-file already in the library
of precompiled M-files.

Arguments may only be defaulted at
the end of an argument list.

You have modified the
VB script generated
for Excel-builder and
have not provided one
or more arguments
used in the modified
script.

Provide a value for any
argument that requires an
explicit value. Arguments
that accept defaults appear
at the end of the argument
list.
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Required Locations to Develop and Use Components

Development Machine

Target Machine

MCR | Make sure that Verify that
matlabroot\bin\win32 mer_root\ver\runtime\win32
appears on your system appears on your system path.
path ahead of any other (mcr_root is your root MCR
MATLAB installations. directory.)

(matlabroot is your root
MATLAB directory.)
CTF Verify that the CTF file is in the same directory as your program’s

executable file.
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Excel Errors and Suggested Solutions

Message

Probable Cause

Suggested Solution

The Macros in this project
are disabled. Please refer
to the online help or
documentation of the host
application to determine
how to enable macros.

Note: Wording may vary
depending upon the version
of Excel you are running.

The macro security for Excel
is set to High.

Set Excel macro
security to Medium on

the Security Level

tab.Tools > Macro > Security.

Function Wizard Problems

Problem

Probable Cause

Suggested Solution

The Function Wizard Help
does not display.

The Function Wizard Help
file (m1function.chm) is not
in the same directory as
the Function Wizard add-in
(mlfunction.xla).

Copy the Help file
(mlfunction.chm) into the
same directory as the add-in.
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Examples

Use this list to find examples in the documentation.
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Calling a MATLAB Function from Excel

“Magic Square Examples” on page 4-2



Using Multiple Files and Variable Arguments

Using Multiple Files and Variable Arguments
“Using Multiple Files and Variable Arguments” on page 4-8
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Creating a Comprehensive Excel Add-in: Spectral Analysis
“Spectral Analysis Example” on page 4-17
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Querying the Registry

“Obtaining Registry Information” on page A-6
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